Google Earth / Trimble Sketchup

Сomentários

Transcrição

Google Earth / Trimble Sketchup
GeoInfo zum Ausprobieren:
Google Earth und eigene 3D-Gebäude
EarthViewer / 3D-Programm:
Google Earth / Trimble Sketchup
Hochschule Karlsruhe, Fakultät für Informationsmanagement und Medien, September 2014
Google Earth / Trimble Sketchup
Inhalt
Einleitung...........................................................................Seite 3
1. Google Earth..................................................................Seite 4
2. Sketchup I......................................................................Seite 7
3. GIMP..............................................................................Seite 9
4. Sketchup II...................................................................Seite 10
Hochschule Karlsruhe, Fakultät für Informationsmanagement und Medien, September 2014
2
Google Earth / Trimble Sketchup
Einleitung
Diese Übung gibt zuerst eine Übersicht über die Möglichkeiten des Hinzufügens
von eigenen Daten/Dateien (z.B. Grundrisspläne als Bilddatei). Es wird beschrieben wie man das Programm Google Sketchup in Verbindung mit Google Earth
dazu nutzen kann auf einfache Art und Weise dreidimensionale Gebäude an einen bestimmten Ort zu zeichnen. Außerdem wird erläutert auf welche Weise man
eigene Fotos von Gebäudefassaden (mit einer normalen Digitalkamera aufgenommen) so aufbereiten kann, dass man sie in Google Sketchup als Textur auf
sein zuvor erstelltes 3D-Gebäude mappt (eine Fläche mit einer Textur belegen).
Abschließend wird erklärt wie man das Ergebnis zurück nach Google Earth exportieren kann.
Download
Google Earth gibt es kostenlos zum Download unter:
https://earth.google.de
Trimble Sketchup gibt es kostenlos zum Download unter:
http://www.sketchup.com
Hochschule Karlsruhe, Fakultät für Informationsmanagement und Medien, September 2014
3
Google Earth / Trimble Sketchup
1. Google Earth
In Google Earth finden Sie Satellitenbilder, Karten, Geländeinformationen und 3DGebäude von der gesamten Welt sowie Ansichten von fernen Galaxien und Unterwassercanyons. Sie können komplexe geografische Gegebenheiten erkunden,
interessante Orte speichern und diese mit anderen Nutzern austauschen.
(Quelle: Deutsche Google Earth Homepage unter http://earth.google.com/intl/de/)
In obiger Abbildung sieht man die Benutzeroberfläche von Google Earth und das
Gelände der Hochschule Karlsruhe. Auf der linken Seite befindet sich oben eine
Suchfunktion.
Darunter befindet sich die Orteverwaltung. Hier erscheinen hinzugeladene Informationen, die von Google und anderen erstellt wurden, wie Fotos, das Wetter
oder Karten.
Links unten gibt es eine Ebenenverwaltung, mit der einzelne Ebenen wie „Grenzen und Beschriftungen“, „Straßen“ oder „3D-Gebäude“ sichtbar oder unsichtbar
geschaltet werden können.
Hochschule Karlsruhe, Fakultät für Informationsmanagement und Medien, September 2014
4
Google Earth / Trimble Sketchup
Mit dieser Navigationshilfe ist es möglich, die Blickrichtung vom
aktuellen Standpunkt zu ändern. Bei einem Klick auf das „N“
wird die Ansicht automatisch nach Norden ausgerichtet.
Dieses Werkzeug dient zum Verschieben des Bildausschnitts.
Das Hinein- und Herauszoomen ist mit diesem Werkzeug möglich. Bei starkem Hereinzoomen neigt sich die Blickrichtung.
Das Programm Google Earth bietet nicht nur Möglichkeiten zum Erkunden der
Welt, sondern auch die Möglichkeit aktiv die Ansicht der Welt mitzugestalten. Ein
Beispiel ist das Hinzufügen eigener Bilddateien (z.B. .jpg,.tif,.png - Format):
In der Menüleiste gibt es unter dem Punkt „Hinzufügen“ die Option „Bild Overlay“
Nach dem Anwählen dieser Option öffnet sich ein neues Fenster, in dem es die
Möglichkeit gibt über „Durchsuchen“ eine Datei auszuwählen. In der Abbildung
unten eine Grundrissplan der Hochschulgebäude und einiger umliegender Wohnhäuser.
Hochschule Karlsruhe, Fakultät für Informationsmanagement und Medien, September 2014
5
Google Earth / Trimble Sketchup
Um das eingefügte Bild transparenter zu machen, damit das
Satellitenbild sichtbar wird, gibt
es die Möglichkeit anhand eines
Schiebereglers die Transparenz
zu steuern.
Nachdem das Satellitenbild sichtbar ist, gibt es die Möglichkeit das Bild anhand
der grünen Rahmen-Elemente (siehe Abbildungen Seite 5, unten) zu verschieben
(grünes Element in der Mitte), zu drehen (grünes rautenförmiges Element links)
und in eine bestimmte Richtung zu vergrößern und zu verkleinern (grüne Elemente an den Seitenmitten und Ecken) um es so an das Satellitenbild anzupassen.
Auch wenn das Bild nicht georeferenziert ist, so lässt es sich zumindest mit einer
gewissen Genauigkeit an die geographischen Gegebenheiten anpassen. Für bestimmte Zwecke ist diese Methode ausreichend.
Google Earth bietet jedoch auch die Möglichkeit georeferenzierte Daten hinzu zu
laden. Das bedeutet, dass die Daten bereits einen Bezug zu einem bestimmten
Koordinatensystem haben. Damit können die Daten automatisch mit einer hohen
Genauigkeit auf der entsprechenden Stelle im Satellitenbild platziert werden. Dabei sollte die Datei am Besten im .kml (Keyhole Markup Language) - Format vorliegen. Vor allem GIS (Geoinformationssystem) - Programme aber auch andere
Programme können Daten in dieses Format exportieren. In der Menüleiste kann
man über „Datei“ > „Öffnen“ die Datei auswählen, in unten zu sehendem Beispiel
die Datei „GPS_Koordinaten.kml“. Dabei handelt es sich um einen GPS Track, der
bei einem Rundgang durch das Gelände des Karlsruher Schlossparks aufgenommen wurde. Die als Stecknadeln dargestellten Punkte geben die Koordinaten, die
dabei automatisch aufgezeichnet wurden, wieder.
Hochschule Karlsruhe, Fakultät für Informationsmanagement und Medien, September 2014
6
Google Earth / Trimble Sketchup
2. Sketchup (Teil 1)
Der nächste Abschnitt befasst sich mit dem Import eines Ausschnitts des Google
Earth Satellitenbilds in Sketchup sowie der Modellierung eines einfachen 3DGebäudes.
„Sketchup ist eine Software, mit der Sie 3D-Modelle von beliebigen Objekten erstellen können.“ (Quelle: http://sketchup.google.com/intl/de/product/gsu.html)
In dem Programm Sketchup gibt es in der oberen Menüleiste unter „Ansicht“ >
„Symbolleisten“ die Option „Google“. Daraufhin erscheint eine kleine Funktionsleiste:
Mit dem ersten Button, auf dem das Google Earth Symbol mit einem gelben Pfeil
zu sehen ist, kann man die „Aktuelle Ansicht übernehmen“. Hierbei muss Google
Earth geöffnet und der gewünschte Ausschnitt zu sehen sein. Nach einem Klicken
auf diesen Button startet der Importvorgang und Sketchup übernimmt den aktuellen Ausschnitt aus Google Earth (siehe Abbildung oben rechts).
Nun gibt es einige Buttons in der Werkzeugleiste die zur Navigation in Sketchup
benötigt werden (im Folgenden werden nur die wichtigsten genannt):
„Rotieren“ Werkzeug: Mit diesem ist es möglich sich im Raum in alle
Richtungen zu drehen
„Schwenken“ Werkzeug: Zum Verschieben der Szene
„Zoomen“ Werkzeug: Hiermit kann hinein- und hinausgezoomt werden
Hochschule Karlsruhe, Fakultät für Informationsmanagement und Medien, September 2014
7
Google Earth / Trimble Sketchup
Um nun ein 3D-Gebäude auf den Ausschnitt des Satellitenbilds zu zeichnen, sollte
zuerst die Ansicht so eingestellt werden, dass das Satellitenbild ungefähr senkrecht von oben zu sehen ist.
Anschließend wird das Zeichnen-Werkzeug „Rechteck“ ausgewählt
„Rechteck“ Werkzeug
und auf einem, auf dem Satellitenbild befindlichen, Gebäude aufgezogen. Dabei
sollte es einigermaßen genau von einer Ecke zu der diagonal gegenüberliegen
Ecke gezogen werden (siehe Abbildung unten links). Sind die Maße des Gebäudes bekannt, so können diese, sobald das Rechteck gezeichnet wurde, über die
Tastatur eingegeben werden - Länge und Breite werden dabei mit einem Semikolon getrennt. Die Werte erscheinen in dem kleinen Fenster rechts unten:
Dabei ist es wichtig, dass auch die richtigen Maßeinheiten ausgewählt sind. In
unserem Beispiel wollen wir dezimale Einheiten in Metern. Die Maßeinheiten lassen sich in der Menüleiste unter „Fenster“ > „Modellinformationen“ > „Einheiten“
festlegen.
Nun kann das eben gezeichnete Rechteck (Gebäudegrundriss) mit dem folgenden Werkzeug in die dritte Dimension gezogen werden.
„Drücken/Ziehen“ Werkzeug: Hiermit kann man eine beliebige Fläche in die
dritte Dimension drücken bzw. ziehen
Um nun die genaue Höhe/Tiefe der Fläche anzugeben, kann wie beim Zeichnen
des Rechtecks zuvor einfach eine Zahl über die Tastatur eingegeben und mit der
Enter-Taste bestätigt werden. Das Ergebnis ist in der Abbildung oben rechts zu
sehen.
Im nächsten Schritt soll das Gebäude eine photorealistische Textur erhalten, um
so die Besonderheiten des jeweiligen Gebäudes zu betonen. Hierfür müssen
als erstes einmal Bilder von den verschiedenen Seiten des Gebäudes gemacht
Hochschule Karlsruhe, Fakultät für Informationsmanagement und Medien, September 2014
8
Google Earth / Trimble Sketchup
werden, wobei eine gewöhnliche Digitalkamera vollkommen ausreicht.
Unter dem nächsten Punkt wird kurz erläutert, wie man mit dem kostenlosen Bildbearbeitungs-Programm GIMP die digitalen Photos nachbearbeiten kann, um eine
schönere Textur für das Gebäude zu erhalten.
3. GIMP (kostenlose Software zur Bildbearbeitung)
Um schnell und einfach ein Photo einer Gebäudefassade zu entzerren und
zurechtzuschneiden bietet sich das Freeware-Programm GIMP an.
Wird ein Photo einer Gebäudefassade gemacht, so erscheint das Gebäude durch
den Betrachtungswinkel perspektivisch verzerrt (siehe Abbildung oben links). Da
wir das Photo jedoch als Textur auf unsere rechtwinklige Fläche des Sketchup
Modells bringen wollen, ist es notwendig das Photo zu entzerren. Mit dem Tool
„Perspektive“ lässt sich dies auf einfache Art Weise realisieren. Dazu müssen die
Ecken des Gebäudes mithilfe der lila Viereck-Anfasser so verschoben werden,
dass sich die Gebäudeecken in den Ecken des gelb-schwarz gestrichelten Rahmens befinden.
Hochschule Karlsruhe, Fakultät für Informationsmanagement und Medien, September 2014
9
Google Earth / Trimble Sketchup
Das Ergebnis nach diesem Bearbeitungsschritt ist in der Abbildung rechts
zu sehen. Wie bei vielen Gebäuden
gibt es natürlich das Problem, dass
sich Objekte, vor allem Bäume, davor
befinden. GIMP bietet auch die Möglichkeit diese zu retuschieren, jedoch
würde es den Rahmen dieses Tutorials sprengen dies zu erläutern. Verwiesen sei hier auf das Photoshopund GIMP-Modul unserer Fakultät.
2. Sketchup (Teil 2)
Damit die Textur auf dem zuvor mit Sketchup gezeichneten Gebäude auch gut
passt, sollten die Maße des Gebäudes oder zumindest das Verhältnis zwischen
Länge und Breite der Fassadenfläche einigermaßen stimmen.
Die Fläche bzw. Fassade muss hierzu mittels des schwarzen Mauszeigers in der
Werkzeugleiste aktiviert werden und erscheint dann standardmäßig in blauer Farbe. Anschließend geht man in der Menüleiste auf „Datei“ > „Importieren…“ und
ein Datei-Auswahlfenster erscheint. Hier kann nun das bearbeitete Fassadenbild
ausgewählt werden. Wichtig ist, dass der Punkt „Als Textur verwenden“ aktiv ist.
Klickt man danach auf „Öffnen“ so sieht man einen Farbeimer als Mauszeiger, der
die untere linke Ecke des nun angezeigten Bildes darstellt. Bewegt man diesen
Farbeimer auf die linke untere Ecke der Fassade unseres 3D-Gebäudes, so erscheint ein kleines grünes Viereck. Von hier aus muss man mit gedrückter linker
Maustaste das Bild bis zur rechten oberen Ecke der Fassade aufspannen, bis
auch hier das grüne Viereck auftaucht. Nachdem man die linke Maustaste losgelassen hat und auf irgendeine Stelle außerhalb der eben texturierten Fassade
klickt, kann man das Ergebnis betrachten (Abbildung unten).
Hat man sein Gebäude rundherum mit Textur versehen, so ist es möglich dieses nach
Google Earth zu exportieren. Über „Datei“ >
„Exportieren“ > „3D-Modell…“ kann man es
als kmz-Datei (Google Earth Format) speichern und anschließend in Google Earth mittels „Datei“ > „Öffnen…“ hinzuladen. Dabei
erscheint das Gebäude an der richtigen geographischen Stelle.
Hochschule Karlsruhe, Fakultät für Informationsmanagement und Medien, September 2014
10

Documentos relacionados