FUNDAMENTOS DE MICROPROCESSADORES Engenharia

Сomentários

Transcrição

FUNDAMENTOS DE MICROPROCESSADORES Engenharia
FUNDAMENTOS DE MICROPROCESSADORES
Engenharia Electrotécnica 2013/2014
Nome:______________________________________________ Nº:___________
A entregar obrigatoriamente no fim da sessão!
Instalação do ambiente MPLAB – T/P
1ª Parte:
Objectivo: Introdução ao ambiente de programação para PICs (microcontroladores
MicroChip) MPLAB.
1 – Comece por instalar o ambiente de desenvolvimento MPLAB no seu computador:
•
•
•
•
•
•
Crie uma directoria c:\tmp (ou New Folder no Desktop) e copie o conteúdo do
CD para essa directoria. Note que quando desligar o computador do LAB essa
directoria será apagada automaticamente (caso do PC LAB)
Crie uma directoria c:\fm e copie para aí os ficheiros Pbe.zip e
MPLAB_quick_start.pdf, MPLAB_users_guide.pdf e 16f627.pdf.
Crie a directoria c:\fm\work e copie para aí o ficheiro SMF84.asm
Atenção: se existir um MPLAB já instalado passe à fase seguinte.
Em c:\tmp execute o ficheiro e extraia para a mesma directoria. Execute depois
o ficheiro Install_MPLABxxx. Siga os passos de instalação indicados.
Em c:\fm extraia os ficheiros de Pbe.zip para essa mesma directoria. Estes
ficheiros poderão ser consultados através do Internet Explorer (abrir Index.htm)
e são uma ajuda em Português (Brasil) sobre PICs.
2 – Abra o MPLAB e execute os seguintes passos:
•
•
•
•
•
Configure -> Select Device --- Select PIC16F627A -> (OK)
Project -> New --- Name = SMF84; Directory = c:\fm\work -> (OK)
Na janela SMF84.mcw: Source Files (Tecla DIR do Rato) -> Add Files
--- c:\fm\work\SMF84.asm -> (Open)
Duplo Click no nome do ficheiro SMF84.asm na janela SMF84.mcw
(deve abrir o ficheiro pronto a editar)
Debugger -> Select Tool --- MPLAB SIM
3 – Verifique que a instalação foi efectuada correctamente:
•
•
•
Project -> Build All
Deve aparecer uma janela com 0 errors! Embora tenha alguns Warnings.
Save and Exit
Volte a entrar no MPLAB e escolha: File-> Recent Workspaces --c:\fm\work\smf84 (Deve voltar à situação inicial).
Nota: O ficheiro MPLAB_quick_start.pdf contém informação interessante para ler
em casa e fazer alguns testes.
2ª Parte:
Objectivo: Utilização do Ambiente MPLAB em Simulação
1 – Trabalhando no projecto SMF84 execute os seguintes comandos:
•
•
•
Introduza uma janela WATCH: View -> Watch
Escolha os registos PCL, WREG, STATUS e PORTB e introduza-os (use Add
Sfr)
Mude STATUS e PORTB para Binário (Click botão (DIR rato) no registo --Properties)
2 – Posicione todas as janelas disponíveis de modo a ficarem bem visíveis e introduza
no código fonte as seguintes alterações e execute os seguintes comandos:
•
Colocar a seguir à etiqueta inic
goto inic
• Faça Build All para gerar o código (sem erros!)
• Comece a Simulação:
- Para executar uma instrução usar F7.
- Indique por palavras o que observa (nomeadamente nos registos na janela
WATCH):
3 – Introduza agora no código fonte as seguintes alterações e execute os seguintes
comandos:
•
Colocar a seguir à etiqueta inic
bsf Port_b, 0
bcf
Port_b, 0
goto inic
• Faça Build All para gerar o código (sem erros!)
• Comece a Simulação:
- Para executar uma instrução usar F7.
- Indique por palavras o que observa (nomeadamente nos registos na janela
WATCH):
4 – Introduza agora no código fonte as seguintes alterações e execute os seguintes
comandos:
•
Colocar a seguir à etiqueta inic
movlw b’00000001’
xorwf Port_b, 1
goto
inic
• Faça Build All para gerar o código (sem erros!)
• Comece a Simulação:
- Para executar uma instrução usar F7.
- Indique por palavras o que observa (nomeadamente nos registos na janela
WATCH). Se ligar um LED ao bit 0 do Porto B o que acontece? Explique o
funcionamento da instrução xorwf. Dica: Veja no manual do PIC.
5 – Introduza agora no código fonte as seguintes alterações e execute os seguintes
comandos:
• Colocar em local desejável: LED EQU 0x01
• Colocar a seguir a inic
movlw LED
xorwf
Port_b, 1
goto
inic
• Faça Build All para gerar o código (sem erros!)
• Comece a Simulação:
- Para executar uma instrução usar F7.
- Que alterações é que observou? Para que serve a directiva EQU?
6 – Retire as instruções que colocou e volte ao código original. Introduza na janela
WATCH os símbolos esq, dir, modo e temp (Add Symbol). Compile e simule.
Finalmente, verifique na directoria de trabalho (c:\am\work) os ficheiros gerados pelo
MPLAB, especialmente o ficheiro SMF84.LST.
7 – Faça exercícios de criação e simulação de novos projectos usando as outras
“sources” usadas nas aulas.

Documentos relacionados