Benutzerhandbuch

Сomentários

Transcrição

Benutzerhandbuch
Kentico CMS 7.0 Benutzerhandbuch
Benutzerhandbuch
Kentico CMS 7.0
1
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Inhalt
Einführung ......................................................................................................................4
Überblick über Kentico CMS ................................................................................................ 4
Anmelden ............................................................................................................................. 4
Überblick über die Benutzeroberfläche ............................................................................... 6
Verwalten meines Profils ................................................................................................8
Ändern meiner E-Mail-Adresse und Spracheinstellung ....................................................... 8
Ändern meines Kennworts................................................................................................... 9
Erste Schritte ................................................................................................................ 10
Erstellen von neuen Webseiten ......................................................................................... 10
Bearbeiten von Seiteninhalten .......................................................................................... 13
Verwenden des Editors ................................................................................................. 15
Verwenden des WYSIWYG-Editors .................................................................................... 15
Formatieren von Texten..................................................................................................... 16
Einfügen von Bildern .......................................................................................................... 17
Erstellen von Verknüpfungen............................................................................................. 19
Einfügen von Tabellen ........................................................................................................ 20
Bearbeiten von strukturierten Dokumenten .................................................................. 22
Erstellen von News-Elementen .......................................................................................... 22
Bearbeiten von News-Elementen ...................................................................................... 24
Löschen, Verschieben und Sortieren von Dokumenten ................................................... 26
Löschen und Wiederherstellen von Dokumenten ............................................................. 26
Ändern der Reihenfolge von Dokumenten ........................................................................ 28
Verschieben von Dokumenten in einen anderen Bereich ................................................. 28
Kopieren von Dokumenten ................................................................................................ 29
Übersetzen von Dokumenten ........................................................................................ 31
Workflow und Verwalten von Versionen ....................................................................... 34
Veröffentlichen von Dokumenten ..................................................................................... 34
Archivieren von Dokumenten ............................................................................................ 36
Verwalten von Versionen und Rollback ............................................................................. 37
Sicherheit ..................................................................................................................... 39
2
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Erteilen von Berechtigungen zur Bearbeitung eines Dokuments ...................................... 39
Newsletter.................................................................................................................... 42
Erstellen von Newsletter-Ausgaben................................................................................... 42
Formulare ..................................................................................................................... 44
Erstellen und Veröffentlichen neuer Online-Formulare .................................................... 44
E-Commerce ................................................................................................................. 50
Erstellen neuer Produkte ................................................................................................... 50
Ändern des Bestellstatus.................................................................................................... 54
Datei-Import ................................................................................................................. 59
Massenimport von Dateien................................................................................................ 59
Umfragen ..................................................................................................................... 62
Erstellen und Veröffentlichen neuer Umfragen................................................................. 62
Foren ............................................................................................................................ 66
Erstellen neuer Foren ......................................................................................................... 66
Moderieren von Forenbeiträgen ....................................................................................... 70
3
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Hinweis:
Im vorliegenden Benutzerhandbuch möchten wir Ihnen die Funktionen von
Kentico CMS anhand einer beispielhaften Unternehmenswebseite
aufzeigen. Ihre individuelle Webseitenanwendung kann davon abweichen.
Einführung
Überblick über Kentico CMS
Kentico CMS für ASP.NET ist eine Software, mit der jemand, der keinerlei
Programmierkenntnisse besitzt, eine leistungsstarke und dynamische Webseite erstellen
kann.
Mit Kentico CMS können Sie den Inhalt Ihrer Webseite schnell, effizient und professionell
verwalten und bearbeiten.
Vor dem Start
Georg hat bereits eine Webseite erstellt, die Sie bearbeiten können ...
Anmelden
1. Öffnen Sie Ihren bevorzugten Webbrowser und gehen Sie zu Ihrer Webseite.
2. Klicken Sie oben in Ihrer Webseite auf Sign in to CMS Desk.
-
4
Dieser Link ist nur im Beispiel der Unternehmenswebseite vorhanden. Auf Ihrer
eigenen Webseite müssen Sie zu http://<Ihre Webseite>/cmsdesk gehen
(z. B.: http://www.meinedomain.com/cmsdesk).
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
3. Geben Sie Ihren Benutzernamen und Ihr Kennwort ein.
4. Klicken Sie auf Log on.
Das System meldet Sie zum ersten Mal bei CMS Desk an.
5
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Überblick über die Benutzeroberfläche
Die Benutzeroberfläche von Kentico CMS besteht aus mehreren Bereichen. Jeder einzelne
Bereich besitzt eigene Funktionen und eigene logische Verknüpfungen zu den anderen
Bereichen. Als Ganzes bilden die Bereiche eine grafische Oberfläche, die einfach zu
bedienen ist und eine schnelle Navigation ermöglicht.
Main menu
View mode
selection
Editing mode
selection
Go to Live Site
Switch to
Site Manager
Site
selection
Current
user
Current
version
Sign Out
button
Document
actions
Content
tree
WYSIWYG
editor
Editable
region
Page in
editing mode
Die Hauptbereiche sind:
6

Hauptmenü: Dort können Sie zwischen den Bereichen Content, My Desk, Tools,
Administration, E-Commerce und Online Marketing wechseln. Meistens werden Sie
jedoch die Registerkarte Content verwenden.

Werkzeugleiste für Dokumentaktionen: Dort können Sie Dokumente erstellen,
löschen, bearbeiten, kopieren, verschieben und sortieren.

Auswahl für den Anzeigemodus: Dort können Sie zwischen Edit, Preview, Live site
und List wählen, je nachdem, ob Sie den Inhalt Ihrer Webseite bearbeiten möchten
oder nur sehen möchten, wie sie in einem Browser dargestellt wird.

Inhaltsbaum: Er zeigt die Struktur Ihrer Webseite an und ermöglicht Ihnen die
Dokumente/Seiten zu organisieren.

Auswahl für den Bearbeitungsmodus: Dort können Sie die Art des Seiteninhalts
wählen, welchen Sie diesen bearbeiten möchten. Sie können direkte Seiteninhalte,
Dokumentenfelder sowie Produkt- oder Dokumenteneigenschaften bearbeiten und
Seitenanalysen anzeigen. Wenn Sie ein Administrator sind, können Sie außerdem
die Seitenvorlage entwerfen und bearbeiten.
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch

7
Bearbeitungs-/Anzeigebereich: Dort wird die gewählte Seite in dem Modus
angezeigt, der in der Werkzeugleiste für die Anzeige und Bearbeitung gewählt
wurde.
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Verwalten meines Profils
Ändern meiner E-Mail-Adresse und Spracheinstellung
Sie erfahren jetzt, wie Sie Ihre E-Mail-Adresse und Spracheinstellung ändern können.
1. Rufen Sie im Hauptmenü die Registerkarte My Desk auf.
2. Wählen Sie im Menüband My profile aus.
3. Navigieren Sie zur Registerkarte Details.
4. Setzen Sie den Cursor in das Textfeld E-mail und geben Sie Ihre E-Mail-Adresse ein.
5. Klicken Sie auf die Dropdown-Liste Preferred content culture und wählen Sie die
gewünschte Sprache aus.
So ändern Sie Ihre E-Mail-Adresse und stellen die gewünschte Standard-Sprache für den
Inhalt ein.
8
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Ändern meines Kennworts
Sie erfahren jetzt, wie Sie Ihr Kennwort für die Anmeldung beim CMS Desk ändern können.
1. Rufen Sie im Hauptmenü die Registerkarte My Desk auf.
2. Wählen Sie im Menüband My profile aus.
3. Wählen Sie die Registerkarte Change password aus.
4. Geben Sie Ihr altes Kennwort in das Textfeld Your existing password ein.
-
Lassen Sie das Feld frei, wenn Sie kein Kennwort für die Anmeldung beim CMS
Desk benötigen.
5. Geben Sie Ihr neues Kennwort in das Textfeld New password ein.
6. Geben Sie das Kennwort erneut in das Textfeld Confirm password ein.
7. Klicken Sie auf Set password.
So ändern Sie das Kennwort für den Zugriff auf den CMS Desk.
9
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Erste Schritte
Erstellen von neuen Webseiten
Lassen Sie uns ganz von vorn beginnen, d. h. mit der Erstellung einer neuen Webseite.
1. Wählen Sie die Stelle im Inhaltsbaum, unter der sich Ihre neue Seite auf Ihrer
Webseite befinden soll.
2. Klicken Sie auf ein vorhandenes Dokument (z. B. Services).
-
10
Die neue Seite wird unter dem Dokument eingefügt, auf das Sie eben geklickt
haben.
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
3. Klicken Sie in der Dokumentenaktions-Werkzeugleiste auf die Schaltfläche New.
-
Rechts im Bearbeitungs-/Anzeigebereich sollten die Arten von Dokumenten
angezeigt werden, die Sie an der gewählten Stelle erstellen dürfen.
4. Klicken Sie für eine Webseite auf die Option Page (menu item).
11
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
5. Geben Sie den Namen Ihre neuen Webseite ein, z.B. System integration.
6. Wählen Sie Use an existing page template und anschließend die Vorlage Corporate
site/Corporate Site - Simple text.
-
Wenn Sie ein Administrator sind, besteht für Sie auch die Möglichkeit, eine
leere Seite zu erstellen und die Webseite von Grund auf neu zu gestalten.
7. Klicken Sie auf Save.
Jetzt wird Ihre Seite System integration im Inhaltsbaum unter der bereits vorhandenen
Seite angezeigt.
Sie haben soeben Ihre erste Seite erstellt!
12
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Bearbeiten von Seiteninhalten
Klicken Sie links im Inhaltsbaum auf die Seite System integration. Rechts im Bearbeitungs/Anzeigebereich wird der Inhalt angezeigt. Da wir die Vorlage mit zwei
Bearbeitungsbereichen verwendet haben, nämlich für Titeltext und Inhaltstext, können wir
nun Informationen in diese Bereiche eingeben.
Bitte stellen Sie sicher, dass in der Werkzeugleiste für den Bearbeitungsmodus die
Registerkarte Page ausgewählt ist. Nur dann ist es möglich, Inhalte in den
Bearbeitungsbereichen Ihrer Seite zu bearbeiten.
13
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
1. Setzen Sie den Cursor in das erste Textfeld und geben Sie System integration ein.
2. Geben Sie in das zweite Textfeld We provide system integration services ein.
3. Klicken Sie oben links auf Save.
Wechseln Sie jetzt in der Bearbeitungsmodus-Werkzeugleiste zu Live site. Es sollte jetzt die
Seite „System integration“ mit aktualisiertem Inhalt angezeigt werden.
Sie haben soeben den ersten Inhalt Ihrer Webseite erstellt!
14
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Verwenden des Editors
Verwenden des WYSIWYG-Editors
In Kentico CMS können Sie mit dem WYSIWYG-Editor (What You See is What You Get)
Webinhalt ohne HTML-Kenntnisse erstellen. Seine Funktionen entsprechend denen von
Microsoft Word.
Öffnen Sie Ihre Seite System integration, wählen Sie den Modus Edit aus und klicken Sie auf
die Registerkarte Page, sodass Sie Inhalte in die Bearbeitungsbereiche eingeben können. Es
sollte die Werkzeugleiste des WYSIWYG-Editors angezeigt werden.
15
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Formatieren von Texten
Sie erfahren jetzt, wie Sie die Dicke und Größe des Textinhalts ändern können.
1. Markieren Sie den Teil des Textes, den Sie ändern möchten (z. B. system integration).
2. Klicken Sie im WYSIWYG-Editor auf das Zeichen für Bold. Der markierte Text verändert
sich unmittelbar.
3. Markieren Sie einen anderen Teil des Textes.
4. Ändern Sie dessen Größe, indem Sie auf das Dropdown-Menü Size klicken und 16
auswählen.
5. Klicken Sie oben auf die Schaltfläche Save.
Wechseln Sie zum Ansichtsmodus Live site, sodass Ihr Text mit geänderter Formatierung
angezeigt wird.
Und so ändern Sie die Formatierung Ihres Textes.
16
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Einfügen von Bildern
Sehr wahrscheinlich möchten Sie gern Bilder auf Ihre Webseite laden. Sie können auch
hierfür den WYSIWYG-Editor verwenden.
1. Wechseln Sie zum Modus Edit.
2. Klicken Sie in der Werkzeugleiste des WYSIWYG-Editors auf das Symbol zum
Einfügen/Bearbeiten von Bildern oder Medien (Insert/Edit image or media).
-
Es wird das Dialogfeld Insert image or media angezeigt.
3. Wählen Sie die Registerkarte Content aus.
4. Klicken Sie im Inhaltsbaum auf das Verzeichnis Images.
-
Rechts sollten die Bilder angezeigt werden, die bereits auf den Server
hochgeladen wurden. Sie können, wenn Sie möchten, eines dieser Bilder
verwenden, statt ein neues hochzuladen.
5. Klicken Sie oben auf New file, um ein neues Bild auf den Server zu laden.
17
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
-
Es wird eine Vorschau des hochgeladenen Bildes angezeigt.
Ändern Sie die Eigenschaften des Bildes (Breite und Höhe sowie Grenzen des Bildes,
vertikale und horizontale Abstände sowie Ausrichtung) wunschgemäß.
6. Klicken Sie auf Insert.
-
Das Bild sollte nun in den Text eingefügt sein.
7. Klicken Sie auf Save.
Wechseln Sie nun zu Live site, um das Ergebnis zu sehen.
Auf die gleiche Weise können Sie Flash-Movies auf Ihre Webseite hochladen.
18
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Erstellen von Links
Sie erfahren jetzt, wie Sie Links zu Ihrer Webseite hinzufügen.
1. Wechseln Sie zurück zum Modus Edit.
2. Markieren Sie den Text, den Sie mit einem Teil Ihrer Webseite verlinken möchten.
3. Klicken Sie in der Werkzeugleiste des WYSIWYG-Editors auf das Symbol zum Einfügen
und Bearbeiten von Links (Insert/Edit Link).
-
19
Es wird das Dialogfeld „Insert Link“ geöffnet.
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
4. Wählen Sie die Zielseite aus und klicken Sie auf Insert.
-
Bitte beachten Sie, dass Sie das Ziel, auf das der Link weisen sollte, auswählen
können. Mögliche Optionen sind: Attachments, Content, Media Libraries, Web,
Anchor, E-mail.
5. Klicken Sie im Dokument auf Save.
Wechseln Sie zum Modus Live site. Wenn Sie auf den neu erstellten Link klicken, sollten Sie
auf die Seite umgeleitet werden, die Sie im vorherigen Schritt ausgewählt haben.
Einfügen von Tabellen
Sie erfahren jetzt, wie Sie eine Tabelle in Ihre Webseite einfügen.
1. Klicken Sie in der Werkzeugleiste des WYSIWYG-Editors auf das Symbol zum
Einfügen/Bearbeiten von Tabellen (Insert/edit table).
20
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
2. Ändern Sie im Dialogfeld Table Properties die Anzahl der Zeilen auf 4 und die Anzahl
der Spalten auf 5.
3. Geben Sie My table in das Feld Caption ein.
4. Klicken Sie auf OK.
Sie haben nun eine Tabelle zum Webinhalt hinzugefügt.
21
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Bearbeiten von strukturierten Dokumenten
Im Gegensatz zu Seiten mit Bearbeitungsbereichen besitzen strukturierte Dokumente
besondere Felder, die ausgefüllt werden müssen. Beispielsweise verfügt die Seite „News“
über Felder für den News-Titel, das Veröffentlichungsdatum, die News-Übersicht und den
News-Text.
Diese Felder können auf der Registerkarte Form, jedoch nicht auf der Registerkarte Page
bearbeitet werden.
Erstellen von News-Elementen
Sie erfahren jetzt, wie Sie ein News-Element erstellen und zum News-Bereich hinzufügen.
Hinweis:
Ihr News Dokumententyp muss zu dem Bereich hinzugefügt werden, der ihn
anzeigen soll. Im Beispiel Corporate Site ist es die Seite News, auf Ihrer Seite
ist es möglicherweise eine andere Seite. Bitte setzen Sie sich mit dem
Administrator in Verbindung.
1. Klicken Sie im Inhaltsbaum auf die Seite News.
2. Klicken Sie in der Dokumentenaktions-Werkzeugleiste auf die Schaltfläche New.
22
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
3. Wählen Sie den Dokumententyp News aus.
4. Geben Sie News-Dokumenteneigenschaften ein:

Geben Sie im Feld News Title den News-Titel My first news ein.

Klicken Sie auf die Schaltfläche Now, um den Wert Release date einzugeben.

Geben Sie im Feld News Summary My first news summary ein.

Geben Sie im Feld News Text My first news ein und überspringen Sie die restlichen
Felder.
5. Klicken Sie auf Save and create another.
6. Geben Sie die Einzelheiten eines zweiten News-Dokuments ein:

Geben Sie im Feld News Title My second news ein.

Klicken Sie auf die Schaltfläche Now, um den Wert Release date einzugeben.

Geben Sie im Feld News Summay My second news summary ein.

Geben Sie im Feld News Text My second news text ein und überspringen Sie die
restlichen Felder.
7. Klicken Sie auf Save.
23
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Klicken Sie im Inhaltsbaum auf die Seite News und wechseln Sie zum Modus Live site. Ihre
beiden neu zur News-Seite hinzugefügten Elemente werden jetzt angezeigt.
Sie wissen nun, wie ein News-Element hinzugefügt wird.
Bearbeiten von News-Elementen
Sie erfahren jetzt, wie Sie den Inhalt des News-Elements bearbeiten, das Sie eben erstellt
haben.
1. Klicken Sie im Inhaltsbaum auf My First news.
2. Wählen Sie die Registerkarte Form aus.
3. Ändern Sie den Text News Summary in My first news updated summary.
4. Ändern Sie den Text News Text in My first news updated text.
5. Klicken Sie auf Save.
24
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Wechseln Sie zu Live site, um Ihre aktualisierten News anzuzeigen.
25
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Löschen, Verschieben und Sortieren von
Dokumenten
Löschen und Wiederherstellen von Dokumenten
In diesem Abschnitt erfahren Sie, wie Sie ein Dokument löschen und es später
wiederherstellen.
1. Klicken Sie im Inhaltsbaum auf das Verzeichnis My second news.
2. Klicken Sie in der Dokumentenaktions-Werkzeugleiste auf die Schaltfläche Delete.
3. Vergewissern Sie sich, dass das Kontrollkästchen Destroy document and its history
NICHT aktiviert ist. Damit würde das Dokument vollends gelöscht und kann nicht mehr
wiederhergestellt werden.
4. Klicken Sie auf Yes. (Die Option „Destroy document“ wird u. U. nur angezeigt, wenn Sie
über ausreichende Berechtigungen verfügen.)
26
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
5. Um das Dokument wiederherzustellen, klicken Sie nun im Hauptmenü auf die
Registerkarte My desk.
6.
Klicken Sie oben im Dokumentenbereich auf das Papierkorbsymbol (Bin).
- Alle gelöschten Dokumente werden rechts angezeigt.
7. Gehen Sie zu dem Dokument, das Sie eben gelöscht haben, und klicken Sie auf
Restore.
8. Gehen Sie zurück zur Registerkarte Content. Sie sehen, dass das wiederhergestellte
Dokument My second news am Standardspeicherort abgelegt wurde.
Sie haben soeben gelernt, wie ein Dokument gelöscht und wiederhergestellt wird.
27
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Ändern der Reihenfolge von Dokumenten
Hier erfahren Sie, wie Sie im Inhaltsbaum die Reihenfolge von Dokumenten ändern.
1. Klicken Sie auf die Seite im Inhaltsbaum, die Sie verschieben möchten (z. B. die Seite
Services der Corporate Site).
2. Klicken Sie in der Dokumentenaktions-Werkzeugleiste auf die Schaltfläche Down.
- Ihre Seite wurde verschoben.
Wechseln Sie zum Ansichtsmodus Live site, um zu sehen, dass Ihre Seite auch im
Hauptmenü verschoben wurde.
Verschieben von Dokumenten in einen anderen Bereich
Bitte beachten Sie, dass die Schaltflächen Up und Down der DokumentenaktionsWerkzeugleiste Dokumente nur innerhalb einer Ebene des Inhaltsbaums verschieben. Das
Verschieben von Dokumenten an jede beliebige Stelle der Webseite ist mit der Schaltfläche
Move möglich.
1. Klicken Sie auf die Seite, die Sie im Inhaltsbaum verschieben möchten (z. B. auf die
Seite Services).
2. Klicken Sie in der Dokumentenaktions-Werkzeugleiste auf die Schaltfläche Move.
- Das Dialogfeld Move document wird angezeigt.
3. Klicken Sie auf das Dokument, zu dem Sie Ihre Seite verschieben möchten (z. B. zum
Abschnitt Company).
28
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
4. Klicken Sie unten auf die Schaltfläche Move.
Ihre Seite wurde an die gewünschte Stelle verschoben.
Kopieren von Dokumenten
Jetzt erfahren Sie, wie ein Dokument von einer Stelle an eine andere kopiert wird.
1. Klicken Sie im Inhaltsbaum auf das Dokument, das Sie kopieren möchten (z. B. die Seite
News).
2. Klicken Sie in der Dokumentenaktions-Werkzeugleiste auf die Schaltfläche Copy.
29
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
3. Klicken Sie im Dialogfeld Copy document auf die Stelle, an die Sie Ihr Dokument
kopieren möchten (z. B. den Abschnitt Company).
- Wenn Sie alle darunter befindlichen, untergeordneten Dokumente kopieren
möchten, aktivieren Sie bitte die Option Copy also child documents.
4. Klicken Sie unten auf die Schaltfläche Copy.
Sie wissen nun, wie ein Dokument kopiert wird.
30
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Übersetzen von Dokumenten
Sie möchten Ihre Webseite u. U. in mehreren Sprachen anbieten, sodass Besucher mit
verschiedenen kulturellen Hintergründen davon profitieren können.
Hinweis:
Für diesen Abschnitt des Handbuchs muss Ihre Webseite für mehrere
Sprachversionen konfiguriert werden. Die Kennzeichnungsauswahl in der
Sprachwerkzeugleiste sollte angezeigt werden (bei mehr als 5 Sprachen wird
stattdessen eine Dropdown-Liste angezeigt). Wenn Sie nicht angezeigt wird,
sollten Sie Ihren Administrator kontaktieren, damit er den mehrsprachigen
Support für Sie konfiguriert.
1. Stellen Sie sicher, dass der Bearbeitungsmodus aktiviert ist.
2. Wählen Sie in der Kennzeichnungsauswahl (oder im Dropdown-Menü Language) die
Sprache aus, in die Sie Ihre Dokumente übersetzen möchten.
31
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
3. Klicken Sie im Inhaltsbaum auf eines der Dokumente mit einem kleinen Kreuz.
- Das Kreuz zeigt an, dass das Dokument bislang nicht übersetzt wurde.
- Es wird ein Dialogfeld für die Übersetzung des Dokuments anzeigt.
4. Wählen Sie die Option Copy content from another language aus.
5. Wählen Sie die Sprachversion aus, aus der das Dokument kopiert werden soll.
6. Klicken Sie auf die Schaltfläche Create document.
7. Geben Sie in das Feld Document name den übersetzten Titel Ihrer Seite ein.
8. Klicken Sie auf Save.
32
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
9. Wechseln Sie zum Bearbeitungsmodus Page. Sie können jetzt mit dem Übersetzen des
Webseiteninhalts beginnen.
- Bitte beachten Sie, dass Sie die Masterseite (das Stammdokument) sowie den
gesamten Inhalt der Seite übersetzen müssen.
Sie wissen nun, wie ein Dokument in eine andere Sprache übersetzt wird.
33
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Workflow und Verwalten von Versionen
Hinweis:
Wir gehen davon aus, dass Ihre Webseite im Workflow-Tutorial für den
Workflow konfiguriert wurde. Wenden Sie sich für weitere Informationen an
Ihren Administrator oder schlagen Sie im Entwicklerhandbuch zu Kentico CMS
nach.
Veröffentlichen von Dokumenten
Hinweis:
In diesem Teil des Benutzerhandbuchs verwenden wir ein Beispiel mit drei
Workflow-Standardschritten: Bearbeiten, Veröffentlichen, Archivieren. Für
Ihre Webseite sind möglicherweise andere Workflow-Schritte erforderlich.
Das Verfahren ist jedoch das gleiche.
1. Wählen Sie links im Inhaltsbaum das Dokument aus, das Sie bearbeiten möchten.
- Oben im Bearbeitungs-/Anzeigebereich befindet sich eine Leiste, die den aktuellen
Workflow-Schritt anzeigt: Edit.
2. Bearbeiten Sie den Inhalt Ihrer Seite.
34
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
3. Klicken Sie auf Save.
4. Wechseln Sie zum Anzeigemodus Preview.
- Sie sehen, dass Ihre Seite aktualisiert wurde. Allerdings werden Ihre Änderungen
noch nicht im Ansichtsmodus Live site angezeigt, da die aktualisierte Seite noch
nicht veröffentlicht wurde und sich noch im Schritt Edit befindet.
5. Klicken Sie auf das Symbol Publish.
Wechseln Sie nun zu Live site, wo die bearbeitete Seite veröffentlicht wurde und nun auf
Ihrer echten Webseite angezeigt wird.
So müssen Sie also vorgehen, um Ihr Dokument zu veröffentlichen.
35
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Archivieren von Dokumenten
Ein archiviertes Dokument wird für Besucher nicht sichtbar in einer Datenbank
abgespeichert, von wo aus es jederzeit wieder bereitgestellt werden kann.
1. Wählen Sie das Dokument aus, das Sie im Inhaltsbaum archivieren möchten.
2. Wählen Sie den Ansichtsmodus Edit aus.
3. Wählen Sie die Registerkarte Properties aus.
4. Wechseln Sie links im vertikalen Menü zur Registerkarte Workflow.
5. Klicken Sie auf die Schaltfläche Archive.
So nehmen Sie also ein Dokument von der Webseite und speichern es im Archiv.
36
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Verwalten von Versionen und Rollback
Sie möchten möglicherweise eine Liste mit früheren Versionen Ihres Dokuments
durchsuchen und eine ältere Version auf der Webseite veröffentlichen. Dafür können Sie
die Versionsverwaltung und das Rollback von Kentico nutzen.
Hinweis:
Die Versionsverwaltung und das Rollback funktionieren nur bei Dokumenten,
die den Workflow verwenden.
1. Wählen Sie das Dokument aus, das Sie im Inhaltsbaum ändern möchten.
2. Stellen Sie sicher, dass der Ansichtsmodus Edit aktiviert ist.
3. Gehen Sie zu Properties -> Versions.
- Rechts wird nun die Liste mit den Versionen des Dokuments angezeigt.
4. Wählen Sie die Version aus, die Sie veröffentlichen möchten.
37
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
5. Klicken Sie auf die Schaltfläche Rollback version.
6. Klicken Sie auf OK, um zur gewählten Version des Dokuments zurückzukehren.
7. Wechseln Sie zur Registerkarte Workflow im vertikalen Menü.
- Sie sehen nun, dass sich die wiederhergestellte Version des Dokuments im
Workflow-Schritt Edit befindet. Sie müssen es erneut veröffentlichen, damit es auf
der Live site angezeigt wird.
8. Wechseln Sie zum Bearbeitungsmodus Page und klicken Sie auf Publish.
Wechseln Sie zum Ansichtsmodus Live site, um das veröffentlichte Dokument anzuzeigen.
Sie haben erfolgreich eine ältere Version Ihres Dokuments eingestellt und es auf Ihrer
Webseite veröffentlicht.
38
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Sicherheit
Erteilen von Berechtigungen zur Bearbeitung eines
Dokuments
Hinweis:
Sie müssen über Zugriffsrechte verfügen, mit denen Sie anderen Benutzern
Berechtigungen erteilen dürfen, um diesen Teil des Tutorials bearbeiten zu
können.
Weitere Informationen zur Sicherheit bei Kentico CMS finden Sie im
Developer’s Guide.
1. Wählen Sie im Inhaltsbaum das Dokument aus, dessen Sicherheitseinstellungen Sie
ändern möchten.
2. Stellen Sie sicher, dass der Ansichtsmodus Edit aktiviert ist.
3. Gehen Sie zu Properties -> Security.
39
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
4. Klicken Sie auf die Schaltfläche Add roles.
5. Wählen Sie im Dialogfeld Select roles CMS Editors.
6. Klicken Sie auf OK.
- Es wird nun die CMS Editors-Rolle in die Liste aufgenommen.
40
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
7. Klicken Sie auf die Kontrollkästchen Allow in den Zeilen Read, Modify und Create.
8. Klicken Sie auf OK.
Sie haben der Rolle CMS editors soeben Bearbeitungsberechtigungen für das
entsprechende Dokument gewährt. Auf die gleiche Weise können Sie auch Berechtigungen
für bestimmte Benutzer einrichten.
41
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Newsletter
Sie möchten Ihren Kunden möglicherweise E-Mail-Newsletter zukommen lassen, um sie
über neue Produkte oder andere Themen zu informieren. In Kentico CMS können Sie
innerhalb weniger Minuten E-Mail-Newsletter erstellen und versenden.
Erstellen von Newsletter-Ausgaben
1. Wählen Sie im Hauptmenü von CMS Desk die Registerkarte Tools aus.
2. Wählen Sie im Menüband Newsletters aus.
3. Klicken Sie auf der Registerkarte Newsletters neben Edit auf einen vorhandenen
Newsletter (z.B. auf das Beispiel „Corporate Newsletter“).
4. Klicken Sie auf der Registerkarte Issues auf die Schaltfläche Create new issue.
- Der Assistent für eine neue Ausgabe wird angezeigt. Er führt Sie schrittweise durch
die Erstellung einer neuen Ausgabe.
5. Geben Sie in Schritt 1 des Assistenten folgende Informationen ein:
 My newsletter issue in das Textfeld Subject
42
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
 The content of my newsletter issue in das Textfeld Content
- Sie können auch den WYSIWYG-Editor zum Bearbeiten des Ausgabeinhalts
verwenden.
6. Klicken Sie unten im Dialogfeld auf die Schaltfläche Next.
- Der Inhalt der Ausgabe wird dadurch automatisch gespeichert.
7. Stellen Sie sicher, dass in Schritt 2 die Option Send now to all subscribers ausgewählt
ist.
8. Klicken Sie unten auf die Schaltfläche Finish.
Ihre neue Newsletter-Ausgabe wurde an die Abonnenten verschickt.
Hinweis:
Das Versenden der E-Mails kann einige Zeit in Anspruch nehmen, wenn es
eine große Zahl Abonnenten gibt. Sie können den Status der E-Mails prüfen,
indem Sie im linken Menü zur Registerkarte Newsletter queue wechseln.
43
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Formulare
Erstellen und Veröffentlichen neuer Online-Formulare
1. Gehen Sie zu Tools -> Forms.
2. Klicken Sie auf New form.
3. Geben Sie Send us a message in das Feld Form display name: ein.
4. Lassen Sie die (automatischen) Werte in den restlichen Feldern unverändert.
5. Klicken Sie auf Save.
Sie haben soeben ein leeres Formular erstellt. Nun müssen Sie einige Attribute zum
Formular hinzufügen:
1. Wechseln Sie zur Registerkarte Fields.
2. Klicken Sie auf das Symbol für ein neues Attribut (New attribute).
44
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
3. Geben Sie die folgenden Werte für die Felder ein:

Column name: FirstName

Field Caption: Enter your first name

Field type: Text box

Maximum length: 15
4. Klicken Sie auf Save.
45
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
5. Klicken Sie wieder auf das Symbol New attribute und geben Sie Folgendes ein:

Column name: LastName

Field caption: Enter your last name

Field type: Text box

Maximum length: 20
6. Klicken Sie auf Save.
7. Klicken Sie erneut auf New attribute, um eine andere Spalte hinzuzufügen, und geben
Sie Folgendes ein:

Column name: Email

Field caption: Enter your e-mail address

Field type: E-mail

Maximum length: 40
8. Klicken Sie auf Save.
46
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
9. Klicken Sie erneut auf New attribute, um die letzte Spalte hinzuzufügen, und geben Sie
Folgendes ein:

Column name: Text

Field caption: Enter your message

Field type: Text area

Maximum length: 1000
10. Klicken Sie auf Save.
Ihr Formular kann nun auf Ihrer Webseite veröffentlicht werden:
1. Wechseln Sie im Hauptmenü zur Registerkarte Content.
2. Wählen Sie im Inhaltsbaum unter Services die Seite System integration aus.
3. Setzen Sie im Bearbeitungsmodus
Bearbeitungsbereich.
Page
den
Cursor
in
den
zweiten
4. Klicken Sie im WYSIWYG-Editor auf die Schaltfläche Insert Form.
47
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
5. Klicken Sie im angezeigten Webdialogfeld auf Select neben dem Feld Form name.
6. Wählen Sie das Formular Send us a message aus.
7. Klicken Sie auf OK.
8. Klicken Sie auf Save.
48
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Wechseln Sie nun zum Modus Preview. Ihr Formular wurde zur Seite System Integration
hinzugefügt.
Nachdem das Formular abgesendet wurde, können die Daten unter CMS Desk -> Tools ->
Forms -> Edit (Your_Form) -> Data gefunden werden. Sie können auch eine E-MailBenachrichtigung unter CMS Desk -> Tools -> Forms -> Edit (Your_Form) -> Notification email einstellen.
Sie haben soeben die Schritte zur Erstellung eines brandneuen Formulars für Ihre Webseite
durchgeführt.
49
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
E-Commerce
Erstellen neuer Produkte
Jetzt erfahren Sie, wie Sie ein neues Produkt für Ihren E-Commerce erstellen.
1. Wählen Sie im Inhaltsbaum Products -> Smartphones aus.
2. Klicken Sie in der Dokumentenaktions-Werkzeugleiste auf die Schaltfläche New.
3. Wählen Sie den Dokumententyp Smartphone.
50
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
4. Geben Sie im Abschnitt General die folgende Information ein:
-
Product name: HTC Evo 3D
Price: 900
Wählen Sie im Dropdown-Menü Department die Option Smartphones aus.
Sie können, wenn Sie möchten, ein Foto des Produkts hochladen.
5. Geben Sie im Bereich Custom properties die folgenden Informationen ein:
-
51
Operating system: Android 2.3 Gingerbread
Dimensions: 127 x 66 x 11,3 mm
Weight: 170 g
Display type: Super-LCD
Display size: 4.3"
Display resolution: 960x540
CPU: Qualcomm Snapdragon Dual-Core 1.2 GHz
RAM: 1 GB
Internal storage: 4 GB
Removable storage: 8 GB Micro-SDHC (expandable up to 32 GB)
Battery type: Li-ion 1730 mAh
Camera: Dual 5 MP
GPS: YES
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
6. Klicken Sie oben auf Save.
- Das System zeigt die Registerkarte Form für das neu erstellte Produkt an.
Sie haben soeben ein neues Produkt erstellt, dem nun eine Steuerklasse und ein
Volumenrabatt zugewiesen werden:
1. Gehen Sie zu SKU -> Tax classes.
2. Klicken Sie auf die Schaltfläche Add tax classes.
3. Wählen Sie Sales tax aus.
4. Klicken Sie auf OK, um die Änderungen zu speichern.
5. Wechseln Sie zur Registerkarte Volume discounts.
6. Klicken Sie auf New volume discount.
- Das System zeigt das Dialogfeld New volume discount an.
7. Geben Sie 10 in das Textfeld Minimum amount ein.
52
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
8. Wählen Sie das Optionsfeld Relative discount aus.
9. Geben Sie 5 in das Textfeld Discount value ein (dadurch werden 5 % Rabatt vom
Produktpreis abgezogen).
10. Klicken Sie auf OK, um das Dialogfeld zu schließen.
11. Wählen Sie im Inhaltsbaum die Seite Smartphones aus.
- Das Produkt wurde nun erfolgreich zu Ihrer E-Commerce-Webseite hinzugefügt.
Sie haben soeben gelernt, wie ein neues Produkt erstellt und eine Steuerklasse sowie ein
Volumenrabatt eingegeben werden.
53
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Ändern des Bestellstatus
In diesem Abschnitt erfahren Sie, wie Sie den Status Ihrer Bestellung ändern.
Zunächst müssen Sie eine Bestellung vornehmen, um den Status ändern zu können.
1. Öffnen Sie in Ihrem Browser Corporate site (ohne sich anzumelden).
2. Wählen Sie im Hauptmenü Products -> Smartphones aus.
3. Klicken Sie auf das Einkaufwagen-Symbol unter HTC Sensation.
54
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
4. Klicken Sie in Schritt 1 (Step 1) unten auf die Schaltfläche Check out.
5. Wählen Sie in Schritt 2 (Step 2) Create a new account und geben Sie die folgenden
Informationen ein:
-
First name: John
Last name: Smith
E-mail (user name): [email protected]
Password/Confirm password: johnsmith1
6. Klicken Sie auf Next.
55
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
7. Geben Sie in Schritt 3 (Step 3) die folgenden Informationen ein:
-
Name (company or personal): Software Development
Address lines: 1020 Blueberry Ln.
City: Tucson
ZIP: 85474
8. Klicken Sie auf Next.
9. Nehmen Sie in Schritt 4 (Step 4) keine Änderungen vor und klicken Sie auf Next.
56
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
10. Klicken Sie in Schritt 5 (Step 5) auf Order now.
Es sollte nun der Bestätigungstext angezeigt werden. Das System hat Ihre Bestellung
erhalten und Sie können jetzt den Bestellstatus ändern.
1. Melden Sie sich beim CMS Desk an.
2. Gehen Sie zu E-commerce -> Orders.
57
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
3. Klicken Sie neben der neu erstellten Bestellung auf Edit.
4. Wählen Sie auf der Registerkarte General im Dropdown-Menü Status die Option
Payment received aus.
5. Klicken Sie auf OK.
Das System hat den Status Ihrer Bestellung erfolgreich erfasst.
58
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Datei-Import
Massenimport von Dateien
In diesem Abschnitt erfahren Sie, wie Sie Dateien und Dokumente in Ihre Webseite
importieren können.
1. Gehen Sie zu Tools -> File import.
- Es sollten nun die Dateien aus dem Verzeichnis angezeigt werden, das die Quelle
für den Datei-Import darstellt. Wenn keine Dateien angezeigt werden, bedeutet
dies, dass sich keine Dateien in Ihrem Datei-Importverzeichnis befinden.
2. Überprüfen Sie oben den Pfad zum Datei-Importverzeichnis und wählen Sie die
Dateien aus, die Sie in dieses Verzeichnis hochladen möchten.
59
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
3. Aktivieren Sie das Kontrollkästchen Select neben der Datei, die Sie importieren
möchten.
4. Klicken Sie auf Select.
5. Wählen Sie im Inhaltsbaum Examples aus.
6. Klicken Sie auf die Schaltfläche Select.
60
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
7. Klicken Sie auf Start import.
Sie haben die gewählte Datei soeben erfolgreich in Ihre Webseite importiert.
61
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Umfragen
Erstellen und Veröffentlichen neuer Umfragen
1. Gehen Sie zu Tools -> Polls.
2. Klicken Sie auf New poll.
3. Geben Sie die folgenden Informationen ein:
-
Display name: Shopping
Code name: Shopping
Title: Shopping
Question: Have you ever bought anything from our website?
4. Klicken Sie auf Save.
62
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
5. Wechseln Sie zur Registerkarte Answers.
6. Klicken Sie auf New answer.
7. Geben Sie Yes als Text ein.
8. Klicken Sie auf Save.
9. Klicken Sie erneut auf New answer.
10. Geben Sie No in das Textfeld Text ein.
11. Klicken Sie auf Save.
12. Wechseln Sie zur Registerkarte View, um sicherzustellen, dass die Umfrage so
angezeigt wird, wie Sie es wünschen.
Sie haben soeben eine Umfrage erstellt, die nun auf Ihrer Webseite veröffentlicht werden
kann:
1. Gehen Sie im Hauptmenü zur Registerkarte Content.
2. Wählen Sie im Inhaltsbaum unter Services die Seite System integration aus.
3. Setzen Sie den Cursor in den Bereich Second Editable region.
63
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
4. Klicken Sie im WYSIWYG-Editorfeld auf das Symbol zum Einfügen von Umfragen (Insert
poll).
-
Das System zeigt das Dialogfeld Widget Properties (Poll) an.
5. Klicken Sie auf Select neben dem Feld Poll name.
6. Wählen Sie die Umfrage Shopping aus.
7. Klicken Sie auf OK.
8. Klicken Sie auf Save.
Wechseln Sie nun zum Modus Preview, um sicherzustellen, dass Ihre Umfrage korrekt
angezeigt wird.
64
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
So erstellen Sie also eine Umfrage und veröffentlichen Sie sie auf Ihrer Webseite.
65
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Foren
Erstellen neuer Foren
Hinweis:
In diesem Teil des Handbuchs nehmen wir an, dass die Forengruppe bereits
erstellt und veröffentlicht ist. Wir nehmen auch an, dass die Benutzer die
Berechtigung haben, Foren zu erstellen.
1. Gehen Sie zu Tools -> Forums.
2. Klicken Sie neben der neu erstellten Forengruppe auf Edit.
3. Klicken Sie auf die Schaltfläche Add forum.
66
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
4. Geben Sie die folgenden Informationen ein:
-
Forum display name: My new forum
Forum code name: MyNewForum
5. Klicken Sie auf Save.
Sie haben soeben ein neues Forum erstellt.
67
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Jetzt erfahren Sie, wie Sie eine neue Diskussion posten.
1. Klicken Sie oben rechts auf der Seite auf Sign out.
- Sie werden auf die Seite Home der Corporate site umgeleitet.
2. Klicken Sie im Hauptmenü auf Community -> Forums.
3. Klicken Sie auf My new forum im Bereich Site forums.
68
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
4. Klicken Sie auf die Schaltfläche New thread.
5. Geben Sie die folgenden Informationen ein:
-
User name: Administrator
E-mail: [email protected]
Subject: Welcome
Post: Welcome to our new forum.
6. Klicken Sie auf OK.
69
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
Sie haben soeben ein neues Forum gegründet und die allererste Diskussion gepostet.
Moderieren von Forenbeiträgen
Jetzt erfahren Sie, wie Sie ein moderiertes Forum erstellen, bei dem jeder Beitrag vor
Veröffentlichung genehmigt werden muss.
1. Gehen Sie zu Tools -> Forums.
2. Klicken Sie neben der neu erstellten Forengruppe auf Edit.
3. Klicken Sie auf die Schaltfläche Add forum.
70
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
4. Geben Sie die folgenden Informationen ein:
- Forum display name: My moderated forum
- Forum code name: MyModeratedForum
5. Aktivieren Sie das Kontrollkästchen Forum is moderated.
6. Klicken Sie auf Save.
Sie haben soeben ein moderiertes Forum erstellt. Als globaler Administrator müssen Sie
Ihre eigenen Beiträge nicht genehmigen, da dies automatisch erfolgt. Daher sollten Sie zum
Testen der Genehmigungsfunktion Folgendes durchführen:
1. Sign out vom CMS Desk.
2. Gehen Sie zu Community -> Forums -> My moderated forum -> New thread.
71
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
3. Geben Sie Ihren Benutzernamen und Ihre E-Mail-Adresse in die Felder User name und
E-mail
4. Geben Sie Welcome als Subject ein und in das Textfeld Post Come try our new
moderated forum.
5. Klicken Sie auf OK.
- Sie haben einen Beitrag veröffentlicht. Damit er jedoch im Forum sichtbar ist, muss
er vom zuständigen Moderator genehmigt werden.
6. Melden Sie sich wieder beim CMS Desk an.
7. Gehen Sie zu Tools -> Forums.
72
www.kentico.com
Kentico CMS 7.0 Benutzerhandbuch
8. Klicken Sie auf die Schaltfläche Approve unter dem Bereich Posts waiting for my
approval.
Alternativ können Sie einen Forumsbeitrag im Forumsbaum suchen und genehmigen:
1. Klicken Sie neben der vorhandenen Forengruppe auf die Schaltfläche Edit.
2. Klicken Sie auf die Schaltfläche Edit neben My moderated forum.
3. Navigieren Sie zum Beitrag Welcome links im Fenster.
4. Klicken Sie auf Approve.
Sie haben soeben einen neuen Beitrag genehmigt, der nun auf Ihrer Webseite angezeigt
wird.
73
www.kentico.com

Documentos relacionados