SKRIPT ZUM PRAKTIKUM PHYSIKALISCH

Сomentários

Transcrição

SKRIPT ZUM PRAKTIKUM PHYSIKALISCH
VERSUCH 5: MIKROSKOPISCHE BILDVERARBEITUNG
THEORETISCHE GRUNDLAGEN
BILDAUFNAHMESYSTEME
UND
DIGITALISIERUNG
Bei herkömmlichen Bildaufnahmesystemen wird beispielsweise mittels einer Fotokamera ein
Bild der Umwelt auf einem Silberhalogenid-Film erzeugt. Dieses Bild besteht aus einem mehr
oder weniger kontinuierlichen Verlauf einer Schwärzung auf der Fläche des Bildes.
Für die Verarbeitung mit einem Rechner muss dieses Bild nun in eine Folge von
computerlesbaren Zeichen umgewandelt werden, wobei die räumliche Beziehung zwischen
den Bildbereichen möglichst genau erhalten bleiben muss. Eine Fotographie kann z.B. durch
einen sog. Scanner in ein digitales Signal (Zeichenfolgen aus Einsen und Nullen = Bitmuster)
umgewandelt – digitalisiert - werden. Hierzu wird die Vorlage zeilenweise abgerastert wobei
jede Zeile noch einmal aus einer Anzahl von diskreten Messpunkten besteht. Diesen Vorgang
nennt man Abtasten oder Rastern. Im Rechner wird ein Bild als eine Matrix von kleinen
Quadraten oder Rechtecken den sog. Rasterpunkten oder pixels (engl. picture elements)
dargestellt. Im einfachsten Fall besitzen diese Pixel nur die Werte 0 oder 1 für schwarz oder
weiß. Dies ist z.B. für alle Bilder die Sie hier in diesem Skript sehen der Fall. Man nennt solche
Bilder Schwarz-Weiß oder Binärbilder.
Bei einem Scanner erkennen lichtempfindliche Photodioden aber auch die Hell-/Dunkel- und
Farb-Unterschiede des Bildes, wobei die Helligkeitswerte für jeden Rasterpunkt über einen A/DWandler (Analog/Digital-Wandler) in sog. Grauwerte umgewandelt werden. Dabei wird der
Bereich zwischen Schwarz und Weiß durch Zahlen aus einem begrenzten Bereich, meist
zwischen 0 und 255 dargestellt. Diesen Vorgang nennt man Quantisierung. Das so entstehende
Grauwertbild ist eine Matrix von Zahlenwerten, welche den jeweiligen Helligkeitswert an den
einzelnen Rasterpunkten angeben.
Farbbilder entstehen analog, indem z.B. durch geeignete Farbfilter einzelne Grundfarben
ausgewählt werden (z.B. RGB für rot-grün-blau) und die Helligkeitswerte (bzw. Farbintensität)
bestimmt werden. Bei RGB-Farbbildern besteht damit jeder Rasterpunkt in der Bildmatrix aus
einem Zahlentripel von Helligkeitswerten für je eine der Grundfarben.
87
VERSUCH 5: MIKROSKOPISCHE BILDVERARBEITUNG
a
c
b
d
Abb. 57: Digitalisierung eines Schwarz-Weiss Bildes a)
Original b) Pixelraster c) quantisiertes Bild d) Bildmatrix
(nach: Haberäcker, verändert)
Zur Bildaufnahme bei Videokameras oder modernen Digitalkameras werden häufig sog. CCDSensoren als lichtaufnehmende Bauelemente eingesetzt. Darunter versteht man „Charge Coupled
Device“ was so viel bedeutet wie „ladungsgekoppeltes Gerät“. Ähnlich wie bei einem Scanner
sind auch hier Photosensoren an der Erzeugung des Bildes beteiligt. Diese sind nun jedoch auf
der ganzen Oberfläche nebeneinander angeordnet, wodurch die Scanbewegung entfällt. Diese
Photosensoren erzeugen eine Spannung, die proportional zur Intensität des aufgenommenen
Lichtes ist. Somit wird direkt ein digitales Bild erzeugt.
Bei Videoaufnahmen erfolgt dies mittels eines Frame-Grabbers (Videodigitizer) – dieser greift ein
Bild („Frame“) der Bildabfolge heraus, tastet dieses Bild zeilen- und spaltenmäßig ab und wandelt
es in eine Binärfolge (Bitmuster) um.
Einige CCD-Sensoren besitzen unterschiedliche Sensordichten in x- und y-Richtung. Dies hat z.B.
zur Folge, dass ein Quadrat als Rechteck dargestellt wird. Dies führt zu Fehlern in der Abbildung.
Um den Fehler in Abbildungen erkennen zu können, muss zunächst die Pixelanzahl der Kamera
in x- und y- Richtung ermittelt werden, um daraus die „aspect ratio“ zu berechnen.
y
x
Abb. 58: Aspect ratio = x/y.
CCD-Kameras für den wissenschaftlichen Gebrauch sollten Square pixels haben, mit einer aspect
ratio nahe bei 1.
88
PHYSIKALISCH-TECHNISCHE METHODEN IN DER BIOLOGIE
Zudem gibt es das Problem, dass nicht alle Sensoren der Kamera exakt miteinander abgestimmt
werden können, d.h. die verschiedenen Sensoren können für denselben Farbton nach der
Digitalisierung teils verschiedene Farbwerte liefern. Durch Kalibrierung mit einem Farbton als
Differenzenbild kann dieser Fehler minimiert werden. Weitere Fehlerquellen: Moirée-Effekt,
Dunkelstrom, Bildrauschen, Shading, Blooming und Smear.
DAS
DIGITALE
BILD
Ein Bild, das aus zwei Farben besteht (s. Schwarz-Weiß-Bild) benötigt zur Speicherung eines
Bildpunktes 1 Bit, da mit dem Binärcode mit einer 0 oder einer 1 beide Farbelemente beschrieben
werden können. Für Grautonbilder mit 256 Grautönen werden zur Speicherung eines
Bildpunktes 8 Bit = 1 Byte benötigt, wobei der Grauwert 0 als schwarz interpretiert wird (s.
geringe Lichtintensität) und 255 als weiß. (Binärcode 28 = 256 Graustufen). Farbbilder hingegen
werden meist nach dem RGB-Modell abgetastet. Hierbei wird jeweils mit den drei Primärfarben
Rot, Grün und Blau das Bild abgerastert, wobei für ein Bild somit drei Matrizen benötigt werden.
Deshalb braucht ein RGB-Bild zur Speicherung pro Bildpunkt 3 x 8 = 24 bit = 3 byte.
Da ein Video in Europa 25 Bilder pro Sekunde (25 Hz Bildwiederholungsfrequenz) aufweist, und
die Einzelbilder große Datenmengen enthalten, müssen die Daten komprimiert werden. Häufig
werden deshalb Bildformate verwendet, welche die Bildinformation reduzieren,. Solche
verlustbehafteten Bildformate sind z.B. JPEG (Joint Photograph Experts Group) für Einzelbilder
oder MPEG (Motion Pictures Experts Group) für Bildfolgen. Bildformate, die ohne Datenverlust
bzw. ohne Datenkomprimierung arbeiten sind z.B. RAW, und BMP, sowie TIFF, GIF gleichfarbige
Bildanteile zusammenfassen und daher die Daten komprimiert speichern.
BILDVERARBEITUNG
Um die Daten eines digitalen Bildes besser auswerten zu können, müssen die Bilder zunächst
bearbeitet (Aufbereitung) und dann verarbeitet werden (Bildauswertung). Hierzu können
verschiedene Operationen an dem Bild durchgeführt werden:
LOKALE OPERATIONEN
Lokale Operatoren wirken auf die einzelnen Pixelwerte und können diese gezielt verändern.
Dabei werden auf jeden Pixel eines Bildes oder Teilbildes konsistent bestimmte
Rechenoperationen angewandt wodurch sich sein Grauwert verändert. In diese Kategorie fallen
viele
der
typische
Bildbearbeitungsoperationen
wie
Helligkeitsanpassung
und
Kontrastverbesserung.
G RAUWERTVERTEILUNG
Die Wirkung lokaler Operatoren lässt sich am besten anhand der Grauwertverteilung eines Bildes
beurteilen. Hierzu wird zunächst ein Histogramm des Bildes erstellt, d.h. die
Häufigkeitsverteilung p(s) gegen die Grauwerte s aufgetragen.
89
VERSUCH 5: MIKROSKOPISCHE BILDVERARBEITUNG
25000
35000
100000
30000
20000
10000
25000
Häufigkeit
15000
Häufigkeit
Häufigkeit
80000
60000
20000
15000
40000
10000
5000
20000
0
5000
0
0
50
100
150
200
250
0
0
50
100
Grauwert
150
200
250
0
50
100
Grauwert
150
200
250
Grauwert
Abb. 59: Bilder mit ihrer Grauwertverteilung. Man erkennt links: guter Kontrast, dunkel, mitte:
Bild ist flau, rechts: Bild zu dunkel.
Ein Bild mit einem hellen und einem dunklen Bereich erzeugt ein Histogramm mit zwei lokalen
Maxima (bimodales Histogramm). Anhand der Häufigkeitsverteilung der Grauwerte können nun
verschiedene Eigenschaften des digitalen Bildes charakterisiert werden: es kann der
durchschnittliche Grauwert und die Standardabweichung (mittlere quadratische Abweichung)
errechnet werden.
25000
25000
20000
20000
15000
15000
Häufigkeit
Häufigkeit
I NVERTIEREN
10000
5000
10000
5000
0
0
0
50
100
150
200
250
Grauwert
0
50
100
150
200
250
Grauwert
Abb. 60: Inversion eines Bildes.
Eine der einfachsten lokalen Operationen ist die Invertierung eines Bildes. Dabei wird das
Histogramm einfach um den mittleren Grauwert des Wertebereichs (z.B. 127 bei 8-bit
Grauwertbildern) gespiegelt. Man erhält so ein Negativ des Ausgangsbildes.
90
PHYSIKALISCH-TECHNISCHE METHODEN IN DER BIOLOGIE
DURCH
HISTOGRAMMNORMIERUNG
45000
45000
40000
40000
35000
35000
30000
30000
Häufigkeit
Häufigkeit
KONTRASTVERSTÄRKUNG
25000
20000
25000
20000
15000
15000
10000
10000
5000
5000
0
0
0
50
100
150
200
250
0
50
100
Grauwert
150
200
250
Grauwert
Abb. 61: Kontrastverbesserung durch Normalisieren.
Hierbei werden die Grauwerte so skaliert, dass das Histogramm des neuen Bildes den ganzen
Grauwertbereich überstreicht. D.h. links und rechts werden im Histogramm nicht vorkommende
Grauwerte abgeschnitten und der dazwischen liegende Bereich an Grauwerten wird durch eine
lineare Kennlinien-Skalierung weiter „auseinander gezogen“ werden. Dadurch wird der Kontrast
des Bildes zwar verstärkt, es kommt durch die Skalierung allerdings zu deutlichen Lücken im
Histogramm.
DURCH
HISTOGRAMM-ANGLEICHUNG (BILDANGEPASST)
45000
45000
40000
40000
35000
35000
30000
30000
Häufigkeit
Häufigkeit
KONTRASTVERSTÄRKUNG
25000
20000
25000
20000
15000
15000
10000
10000
5000
5000
0
0
0
50
100
150
200
250
0
50
100
Grauwert
Abb.
62:
Kontrastverbesserung
Angleichung.
150
200
250
Grauwert
durch
Histogramm-
91
VERSUCH 5: MIKROSKOPISCHE BILDVERARBEITUNG
Hierbei werden die häufigsten Grauwerte eines Bildes am weitesten „auseinander gezogen“. Die
Kennlinie entspricht hier der Kurve der Summenhäufigkeit. Im neuen Histogramm treten alle
Grauwerte gleich häufig auf, das Histogramm wird daher als geebnet bezeichnet.
KONTRASTVERSTÄRKUNG
IN DUNKLEN ODER IN HELLEN
BEREICHEN – G AMMAKORREKTUR
Die meisten Fernseh- und Videomonitore stellen Grauwerte nicht mit einer Linearen
Gradationskennlinie dar. Dies liegt zum einen an den verwendeten Phoshorbeschichtung ist aber
auch eine Adaptation an unsere Sehgewohnheiten, da unser Auge in dunklen Bildbereichen sehr
viel feinere Grauwertabstufungen wahrnimmt als in hellen Bildbereichen. Viele CCD-Kameras
geben die Grauwerte daher nicht direkt proportional zur Bildhelligkeit des Pixels aus sondern mit
einer logarithmischen Gradationskennlinie um wieder eine lineare Graustufendarstellung auf
dem Bildschirm zu erzeugen.
Diese Gradations-Kennlinie wird zur γ-Korrektur an Bildschirmen verwendet. Die Kennlinie
zwischen Grauwerten und Lichtintensität folgt dem Potenzgesetz
G = Iγ
250
Grauwerte γ = 0,45
Grauwerte γ = 2,5
Pixelintensität I
200
150
100
50
0
0
50
100
150
200
250
Grauwert G
Abb.
63:
Gammakorrektur
Gradationskennlinien
bei
Bildschirme haben meist Gammawerte von ca. 2.5 wohingegen der bei Videokameras übliche
Gammafaktor 0,45 beträgt (γ = 1 wäre eine Gerade). Dies stellt dann in der Summe wieder eine
lineare Gradationskennlinie mit γ ≈ 1 her. Eine Veränderung des Gammafaktors eines d.h. die
Anwendung nichtlinearer Gradationskennlinien kann aus den oben genannten Gründen daher
für die Darstellung eines Bildes zu einer Kontrastverbesserung führen. Will man jedoch aus den
Grauwerten Intensitätsinformation ausmessen (Densitometrie) dann sollte darauf geachtet
werden, dass das Bild bis zur Verarbeitung stets mit einem Gammafaktor von 1 aufgenommen
und verarbeitet wird. Ist dies nicht möglich (weil z.B. die Videokamera eine fixe Gammakorrektur
mit g = 0,45 besitzt) so sollte dies nachträglich wieder rückgängig gemacht und eine lineare
Grauwertgradation hergestellt werden.
92
PHYSIKALISCH-TECHNISCHE METHODEN IN DER BIOLOGIE
25000
60000
50000
20000
Häufigkeit
Häufigkeit
40000
15000
10000
30000
20000
5000
10000
0
0
0
50
100
150
200
250
0
50
Grauwert
100
150
200
250
Grauwert
Abb. 64: Wirkung der Gammakorrektur (γ = 2.5)
BINÄRBILDER
DURCH
S CHWELLWERTBILDUNG
40000
35000
Häufigkeit
30000
25000
20000
15000
10000
5000
0
0
50
100
150
200
250
Grauwert
Abb.
65:
Binärisierung
Schwellwertbildung.
eines
Bildes
mittels
Will man in Bildern Objekte identifizieren, um z.B. ihre Größe zu bestimmen muss das Bild
zunächst segmentiert werden. Die einfachste Art der Segmentierung ist die Binärisierung mittels
Schwellwertbildung. Zur Herstellung von Binärbildern aus Grauwertbildern werden auf die
Grauwerte der Pixel ein oder zwei Schwellwerte angewandt. Alle Pixel, die über der Schwelle
oder zwischen den beiden Schwellwerten liegen erhalten im Binärbild den Wert 1 (weiss), alle
anderen den Wert 0 (schwarz). Durch geeignete Wahl des Schwellwertes können so Objekte vom
93
VERSUCH 5: MIKROSKOPISCHE BILDVERARBEITUNG
Hintergrundrauschen isoliert werden. Als Schwellwert wird entweder der Mittelwert aller Pixel
verwendet oder aber das Minimum zwischen zwei Maxima. Es entsteht hierbei ein Binärbild
(Schwarz-Weiß-Bild).
LOOKUP-TABELLEN
Die meisten lokalen Operatoren werden nicht direkt am Speicherbild vollzogen sondern lassen
sich über eine sog. Lookup-Tabelle (LUT, deutsch: Nachschlage-Tabellen) realisieren. LookupTabellen sind Programmkonstrukte zur schnellen Realisierung von komplexen mathematischen
Funktionen bei eingeschränktem diskretem Wertebereich. Dabei wird jedem möglichen
Eingangswert d.h. allen möglichen 256 Grauwerten ein Tabellenplatz zugeordnet aus dem der
neue Grau- oder Farbwert ausgelesen wird. Im Ausgabebild wird dann der Grauwert des
jeweiligen Pixels durch den Wert aus der Lookup-Tabelle ersetzt. Dies spart sehr viel Rechenzeit,
da die Umsetzungsfunktion nur einmal auf die Tabelle angewendet werden muss. Die LUT ist im
Vergleich zur Bildmatrix relativ klein und lässt sich auch leicht mit dem Bild speichern ohne
dieses merklich zu vergrößern.
250
rot
grün
blau
Eingangs-Grauwert
200
150
100
50
0
0
50
100
150
200
250
Ausgabe-Grauwert
Abb. 66: Funktion einer Lookup-Tabelle. Jedem
Grauwertindex
am
Eingang
wird
ein
Grauwert/Farbton für die Darstellung zugeordnet.
Viele Frame-Grabber und Graphikkarten verfügen bereits hardwareseitig über Ausgabe-LUTs,
was solche Operationen dann sehr effizient macht. Ein weiterer Vorteil des Verfahrens besonders
für wissenschaftliche Zwecke besteht darin, dass das Speicherbild d.h. das Original durch
Lookup-Tabellen Operationen nicht verändert wird und daher durch Lokale Operationen kein
Informationsverlust entsteht. Außerdem kann durch die Manipulation der LUT leicht jede
gewünschte Gradationskennlinie erzeugt werden. Die für wissenschaftliche Bilddarstellungen
sehr beliebte Falschfarbendarstellung von Grauwertbildern wird ebenfalls über Lookup-Tabellen
realisiert, bei denen jedem Grauwert eine Farbe zugewiesen wird.
94
250
250
200
200
Eingangs-Grauwert
Eingangs-Grauwert
PHYSIKALISCH-TECHNISCHE METHODEN IN DER BIOLOGIE
150
100
50
rot
grün
blau
150
100
50
0
0
0
50
100
150
200
250
0
Ausgabe-Grauwert
50
100
150
200
250
Ausgabe-Grauwert
Abb. 67: Falschfarbendarstellung über eine Lookup-Tabelle
mit RGB-Ausgangswerten
REGIONALE OPERATIONEN
Im Gegensatz zu den lokalen Grauwerttransformationen an Histogrammen wird bei regionalen
Operationen die Grauwertinformation benachbarter Punkte mit in die Berechnung mit
einbezogen. Typische regionale Operationen sind sog. Filter im Ortsbereich.
N ACHBARSCHFTSBEZIEHUNGEN
BEI QUADRATISCHEN
PIXELN
Bei regionale Operatoren wirken sich benachbarte Punkte auf das Ergebnis aus. Was sind jedoch
bei einer digitalen Bildmatrix benachbarte Pixel? Bei rechteckig oder quadratischen Pixeln
unterscheidet man dabei zwei verschiedene Fälle. Bei der sog. 4er Nachbarschaft zählen nur Pixel
als benachbart, die eine Seite mit dem Zentralpixel teilen. Bei der sog. 8er Nachbarschaft zählen
außerdem noch Pixel, die eine Ecke gemeinsam haben.
a
b
Abb. 68: Nachbarschftsverhältnisse bei quadratischen
Pixelanordnungen
(a)
4er
Nachbarschaft,
(b)
8er
Nachbarschaft.
95
VERSUCH 5: MIKROSKOPISCHE BILDVERARBEITUNG
FILTER
Filter im Ortsbereich (d.h. Filter, die direkt die Grauwertinformation und Lage von Pixeln
verwenden) lassen sich mathematisch als sog. Faltung beschreiben. Bei einer Fatung b ⊗ f werden
zwei Funktionen (hier das Bild b und die sog. Impulsantwort f des Filters) miteinander
verrechnet:
( b ⊗ f ) ( x ) = ∫ b ( λ ) f ( x + λ ) dλ
Da ein Bild stets aus diskreten Pixelwerten besteht wird hier das Faltungintegral als Summe
geschrieben
bx , y =
n
m
∑ ∑
i= − n j= − m
Bx + i , y + j × fi , j
d.h. der neue Grauwert ergibt sich aus der Summe der benachbarten Grauwerte, gewichtet mit
den Koeffizienten der sog. Filter- oder Faltungsmaske. Der erhaltene Wert dann als neuer Wert
des Zentralpixels eingetragen. Damit nach der Faltung die Bildmatrix noch gleich groß ist, muss
das Bild am Rand um eine Pixelbreite vergrößert werden z.B. durch Nullen oder Wiederholung
des Bildes oder Spiegeln des Randes.
Bildmatrix mit erweitertem Rand
Filterkern

Abb. 69:
Randbehandlung bei
Koeffizientenmatrix eines Filters.
Faltung
mit
einer
Je nach Art des Filters und der Faltungsmaskenwerte können dadurch verschiedene Effekte
erzielt werden (Faltungsmaskenwerte sind oft auch negativ!):
TIEFPASS-F ILTER
Eine häufig verwendete Form eines Filters ist der sog. Glättungs oder Tiefpassfilter. Mit einem
Tiefpassfilter werden hohe Frequenzen im Bild eliminiert, wodurch Kanten verschwimmen und
das Bild geglättet wird (aber auch unscharf!).
96
PHYSIKALISCH-TECHNISCHE METHODEN IN DER BIOLOGIE
Abb. 70: Wirkung des Tiefpassfilters.
Bei Tiefpassfiltern sind die Koeffizienten in der Faltungsmatrix stets positiv und summieren sich
zu 1. Ein sehr einfaches Beispiel für solch einen Filter ist der sog. Boxcar-Filter mit der
Koeffizientenmatrix
1
9

1
f= 
9
1

 9
1
9
1
9
1
9
1
9

1
9
1

9 
Weitere häufig verwendete Tiefpass-Filter sind z.B. Gaussfilter. Beachten Sie dabei, dass die
Summe der Filterkoeffizienten stets 1 ergeben muss.
HOCHPASS-F ILTER
Hochpassfilter hingegen eliminieren tiefe Frequenzen, wodurch Kanten schärfer hervorgehoben
werden. Man erreicht dies durch negative Filterindices z.B. die Filtermaske. Ein Beispiel hierfür
ist der sog. Laplace-Operator:
 0 −1 0 
f =  − 1 4 − 1
 0 − 1 0 
Abb. 71: Wirkung des Laplace-Operators.
Zusätzlich gibt es noch den kombinierten Bandpass-Filter, der einen Hoch- und Tiefpassfilter
vereinigt, weshalb hohe und tiefe Frequenzen ausgesondert werden. Zur Detektion von Kanten
können Differenzierer-Masken verwendet werden. Die verschiedenen Filter können auch zur
Bildbearbeitung miteinander kombiniert werden, bis der gewünschte Bildeffekt erreicht ist.
97
VERSUCH 5: MIKROSKOPISCHE BILDVERARBEITUNG
MEDIAN-FILTERUNG
Die bisher gezeigten Filter waten sog. lineare Filter d.h. sie verwenden nur die Operationen
Addition und Multiplikation. Diese Filter haben die Eigenchaft, dass sie sich durch geeignete
Wahl der Koeffizientenmatrix durch eine zeite Filteroperation wieder rückgängig machen lassen.
Eine weitere Klasse von Filteroperationen für die dies nicht gilt sind sog. Rangfilter. Hier wird der
Grauwert des Zentralpixels durch den Wert eines anderen Pixels mit einem bestimmten
statistischen Rang (hier: der Median) ersetzt. Ein Medianfilter dient der Störunterdrückung und
Elimination von Ausreißern ohne hierbei die Schärfe wesentlich zu beeinträchtigen. Hierbei
werden die Grauwerte der Pixel innerhalb des Filter-Fensters sortiert und der mittlere Wert
(Rang: ½) als neues Zentralpixel eingetragen (s. Medianwert im Kapitel Statistik).
Abb. 72: Wirkung eines Medianfilters
MORPHOLOGISCHE OPERATIONEN
EROSION
Bei Binärbildern lassen sich Die oben gezeigten Nachbarschaftsoperatoren nicht anwenden.
Stattdessen werden sog. Morphologische Operatoren verwendet, bei denen Die
Rechenoperationen der Filter durch logische Verknüpfungen ersetzt werden. Handelt es sich
dabei um die UND-Verknüpfung spricht man von Erosion:
si , j = si − 1, j − 1 ∧ si − 1, j ∧ si − 1, j + 1 ∧
si , j − 1 ∧ si , j ∧ si , j + 1 ∧
si + 1, j − 1 ∧ si + 1, j ∧ si + 1, j + 1
D.h. ein schwarzer Pixel wird entfernt, wenn nicht alle seine 8 Nachbarpixel (s. direkte und
diagonale Nachbarn) ebenfalls schwarz sind. Dadurch wird die äußere Schicht eines Objektes
entfernt (Kontraktion). Außerdem werden Störungen z.B. durch einzelne Pixel eliminiert, da
diese bei ggf. wiederholter Erosion verschwinden.
98
PHYSIKALISCH-TECHNISCHE METHODEN IN DER BIOLOGIE
Abb. 73: Wirkung von Erosion.
DILATATION
Werden die benachbarten Pixel durch logisches ODER verknüpft spricht man von Dilatation
si , j = si − 1, j − 1 ∨ si − 1, j ∨ si − 1, j + 1 ∨
si , j − 1 ∨ si , j ∨ si , j + 1 ∨
si + 1, j − 1 ∨ si + 1, j ∨ si + 1, j + 1
d.h. weißer Pixel wird schwarz, wenn einer seiner 8 Nachbarn ebenfalls schwarz ist. Somit wird
das Objekt um einen Pixel rundherum vergrößert und Löcher im Objekt werden geschlossen
(Expansion).
Abb. 74: Wirkung von Dilatation.
Erosion und Dilatationkönnen zur Erzielung geeigneter Bildresultate (z.B. Elimination von
Hintergrundrauschen) beliebig oft wiederholt werden, es muss jedoch darauf geachtet werden,
dass beide Operationen gleich oft durchgeführt werden müssen, z.B. dreimal erodieren und
dreimal dilatieren.
99
VERSUCH 5: MIKROSKOPISCHE BILDVERARBEITUNG
Abb. 75: Wirkung von wiederholter Dilatation und Erosion.
ÖFFNEN
UND
S CHLIESSEN
Die Kombination von Erosion und Dilatation wird oft auch zu einem gemeinsamen
morphologischen Operator zusammen gefasst. Je nach Reihenfolge spricht man dann von Öffnen
(Erosion – Dilatation) oder Schließen (Dilatation – Erosion)
Abb. 76: Wirkung von Öffnen (oben) und Schließen (unten).
BILDSEGMENTIERUNG
Bei der flächenbasierten Segmentierung (Aufteilung des Bildes in Bereiche; z.B. Objekte und
Hintergrund) wird das Opening häufig angewendet. Es wird ein Schwellwert im Histogramm
gebildet und dann werden die Objekte mittels Opening von anderen Objekten isoliert. Hierbei
gilt bei Binärbildern häufig die Definition, dass es sich um ein einzelnes Objekt handelt, wenn
keines der 8 Nachbarpixel ebenfalls zum Objekt gehört. Bei inhomogenen Bildern wird jedoch die
kantenbasierte Segmentierung angewendet, wobei geschlossene Kantenzüge gesucht werden.
Zur Detektion von bewegten Objekten in Zeitreihenbildern wird einfach die Differenz von
aufeinanderfolgenden Bildern berechnet. Bewegt sich ein Objekt, so ändert sich an diesen Stellen
der Grauwert des Bildes stark und die Bewegung kann so verfolgt werden. Oder aber es können
100
PHYSIKALISCH-TECHNISCHE METHODEN IN DER BIOLOGIE
die Verschiebungsvektoren Δx und Δy des gleichen Grauwertes zweier aufeinanderfolgender
Bilder berechnet werden.
GLOBALE OPERATIONEN
Bei Filtermasken-Größen über 50x50 Pixel ist die globale Filterung mit Transformationen die
Methode der Wahl (z.B. zur Elimination von Grauwertstörungen,...). Sie dienen auch der
Datenreduktion und – kompression.
Z WEIDIMENSIONALE DISKRETE FOURIER-TRANSFORMATION (2D-DFT)
Hierbei wird die Bildmatrix S spalten- und zeilenweise mittels Fouriertransformation in eine
komplexe Matrix der Ortsfrequenzen transformiert. Mit dieser Fourier-Transformierten lassen
sich nun verschiedene Bildoperationen leichter durchführen wie die unten gezeigteTiefpassFilterung aber auch z.B. Korrelationen zwischen gegeneinander verschobenen Bildern oder sog.
inverse Filter, bei denen Fehler durch das Abbildungssystem rechnerisch ausgeglichen werden.
Abb. 77: Tiefpass-Filterung im Fourier-Raum durch
Selektion
niedriger
Ortsfrequenzen.
(a)
Originalbild (b) Fourier-Spektrum (c) FourierSpektrum bei dem die hohen Ortsfrequenzen
gelöscht wurden (d) Gefiltertes Bild nach Inversion
der Fourier-Transformation.
Weitere Bildtransformationsmethoden sind z.B.:
•
Diskrete Cosinus-Transformation DCT (s. JPEG und MPEG)
•
Hadamard-Transformation
•
Walsh-Transformation
•
Haar-Transformation
•
Wavelet-Transformation
101
VERSUCH 5: MIKROSKOPISCHE BILDVERARBEITUNG
BROWN’SCHE MOLEKULARBEWEGUNG
Im Jahr 1827 entdeckte der englische Botaniker R. BROWN unter dem Mikroskop, dass
Bärlappsporen in einem Tropfen Wasser ständig eine Zitterbewegung vollführen. Diese
Eigenbewegung der kleinen Teilchen ist vollkommen regellos und wurde als Brown’sche
Molekularbewegung bezeichnet. Mathematisch wird diese Bewegung als sog. random walk
beschrieben. Die Bewegung der Teilchen kommt aufgrund von thermischen Stößen zustande.
Durch Zusammenstöße mit anderen Teilchen ändert sich jeweils die Bewegungsrichtung,
wodurch es zu der charakteristischen Zufallsbewegung des Teilchens kommt.
Abb. 78: Simulation einer „random walk“
Bewegung
Nach der kinetischen Gastheorie besitzen die Teilchen in einem abgeschlossenen System bei einer
bestimmten Temperatur T eine mittlere kinetische Energie von
wkin =
3
kT
2
und damit eine mittlere Geschwindigkeit von
v=
3kT
m
Aufgrund dieser thermischen Bewegung haben die Teilchen die Tendenz, sich gleichmäßig in
dem für sie zugänglichen Raum zu verteilen. So kommt es beispielsweise mit der Zeit zu einer
selbstständigen
Durchmischung verschiedener Stoffe aufgrund der Brown’schen
Molekularbewegung. Dieser Vorgang wird als Diffusion bezeichnet.
DIFFUSION
Diffusion ist ein Stofftransport, der auf der Brown’schen Molekularbewegung beruht, und der
zum Ausgleich eines Konzentrationsgefälles führt. Diffusion ist stets vom Ort höherer
Konzentration zum Ort niedrigerer Konzentration gerichtet. Die Diffusion ist abhängig von der
Temperatur und der Art des diffundierenden Stoffes (Größe und Ladung). Makroskopisch lässt
sich der Stofftransport durch folgende Gleichung beschreiben:
102
PHYSIKALISCH-TECHNISCHE METHODEN IN DER BIOLOGIE
dN
dc
= − DA
dt
dx
(1. Ficksches Diffusionsgesetz)
d.h. die pro Zeitabschnit dt durch eine gedachte Fläche A hindurch tretende Teilchenzahl dN ist
proportional zur Fläche, dem Konzentrationsgefälle
dc
dx
und der Diffusionskonstanten D. Der
Ausdruck auf der linken Seite der Gleichung wird auch als Teilchenflux J [mol s-1m-2] bezeichnet:
J=
dN
dc
= −D
dt A
dx
Das negative Vorzeichen vor der Diffusionskonstante zeigt auf, dass Diffusion stets vom Punkt
höherer Konzentration zur niedrigen Konzentration verläuft.
Unter der Annahme des Erhaltungssatzes der Masse läßt sich das 1. Fickche Gesetz umformen in
das 2. Ficksche Gesetz:
dc
d2c
= D 2
dt
dx
(2. Ficksches Diffusionsgesetz)
das die Zeitabhängigkeit der Konzentrationsänderung vom Konzentrationsgradienten
d2c
2
dx
beschreibt.
Der Diffusionskoeffizient kann (nach EINSTEIN-STOKES) geschrieben werden als:
D=
kT
f
k = Boltzmann-Konstante 1,38 ×1023 J/K
T = absolute Temperatur in K
f = Reibungswiderstand
Der Reibungswiderstand f ist abhängig von der Viskosität η des Lösungsmittels und dem
Molekülradius r:
f = 6π η r
Daraus ergibt sich dann für den Diffusionskoeffizienten D:
D=
kT
6π η r
Einstein-Stokes Gleichung
103
VERSUCH 5: MIKROSKOPISCHE BILDVERARBEITUNG
Die Diffusion dient nur bei kurzen Distanzen und kleinen Molekülen als geeigneter
Transportmechanismus. Die zur Diffusion über eine bestimmte Strecke erforderliche Zeit ist
proportional zum Quadrat der mittleren Diffusionsstrecke.
x 2 = 2Dt
Einstein-Smoluchowsky-Beziehung
Diese Gleichung gilt auch im zwei- und dreidimensionalen Fall, geht man davon aus, dass die
Bewegungen in die drei Raumrichtungen unabhängig voneinander sind.
2-D:
r 2 = 4 Dt
mit
r 2 = x2 + y2
3-D:
r 2 = 6Dt
mit
r 2 = x 2 + y2 + z2
Für die Bestimmung der Diffusionskonstanten aus Teilchentrajektorien (Abb. 78) dient die
Abtragung des mittleren Verschiebequadrats (MSD: mean squared displacement) gegen die
Zeitdifferenz (MSD/∆t-Plot, Abb. 79). Die Distanzen in den Raumrichtungen müssen für die
Berechnung quadriert werden (s. Formel), da die Wahrscheinlichkeiten für die Bewegung in die
eine oder andere Richtung jeder Achse gleich groß sind und die mittlere Ortsbewegung des
Teilchens vom Ursprung deshalb statistisch gesehen gleich Null ist (Vorzeichenelimination!).
Jeder Punkt im MSD/∆t-Plot ergibt sich aus der Mittelung vieler Verschiebedistanzen für den
gegebenen Zeitschritt. Dies wird dann für möglichst viele Zeitschrittweiten wiederholt. Nach der
Einstein-Smoluchowski-Gleichung ergibt sich dann bei Diffusion eine Gerade.
15.0
MSD / µm
2
12.5
10.0
7.5
-9
D = 3.82 ±0.09x10 cm2/s
5.0
2.5
0.0
0
2
4
6
8
10
∆t/s
Abb. 79: MSD/∆t-Plot zum Nachweis Brownscher
Molekularbewegung
und
Bestimmung
der
Diffusionskonstanten.
EXPERIMENTELLER TEIL
VERSUCHSZIEL
Im Versuch soll nun die Brown’sche Molekularbewegung von Latexkügelchen als Modell
beobachtet werden, da ihre Bildverarbeitung aufgrund der definierten Form einfach ist. Es soll
die Bewegung der Kügelchen mittels Fotosequenzen aufgenommen werden und daraus mittels
Bildverarbeitung am PC der Teilchendurchmesser und der Diffusionskoeffizient bestimmt
104
PHYSIKALISCH-TECHNISCHE METHODEN IN DER BIOLOGIE
werden. Dies erfolgt im zweidimensionalen Fall, da durch die Kamera nur Bewegungen in zwei
Dimensionen dokumentiert werden können. Eine ähnliche Versuchsanordnung wird z.B.
verwendet, um die Diffusion einzelner Membranproteine in der Zellmembran oder die
Bewegung von Vesikeln im Axoplasma von Nervenzellen zu untersuchen
Bildverarbeitungsmethoden: Binärisierung, Opening, flächenbasierte und bewegungsbasierte
Segmentierung
KÖHLERN
DES
MIKROSKOPS
Um eine optimale Bildaufnahme für Ihre späteren Analysen zu gewährleisten ist es notwendig,
vor der Aufnahme die Beleuchtung des Mikroskops zu optimieren. Stellen Sie dazu wie im
Kapitel Optik beschrieben im Hellfeld eine Köhlersche Beleuchtung ein.
Ihr Mikroskop verfügt auch über eine einfache Dunkelfeldbeleuchtung. Diese ist für die
Beobachtung der Latexkügelchen besser geeignet da sie einen besseren Kontrast ermöglicht. Sie
können die Einstellungen der Köhlerschen Beleuchtung direkt für den Dunkelfeldkontrast
beibehalten, und nach dem Köhlern den Einstellring am Kondensor auf Position “D” stellen.
Beachten Sie, dass eine Dejustage der Beleuchtung bei Dunkelfeldbeleuchtung die Bildqualität
erheblich verschlechtert und zu nicht mehr auswertbaren Bildserien führt!
BILDAUFNAHME
MIT DER
MIKROSKOPKAMERA
Um mit der Kamera Bilder aufnehmen zu können, muss die dazugehörige Software IC Capture
Standard (auf dem Desktop) gestartet werden. Die Einstellungen der Software werden je nach
Bedarf ausgewählt. Grundsätzlich sollen Grauwertbilder mit der höchsten Auflösung
aufgenommen werden (PAL_B, Y800 (768x576), 00VIDEO).
KALIBRIERUNG
DER
APPARATUR
Da es bei diesem Versuch auf eine genaue Messung von Abständen ankommt, müssen zunächst
das Mikroskop und die Kamera mit dem Objektmikrometer kalibriert werden. Von dem
Objektmikrometer werden mittels jedem der Objektive (10x, 40x, 100x [mit Öl]) je zwei
Aufnahmen gemacht. Das eine Mal mit der Skala quer, das andere Mal mit der Skala längs. Die
Aufnahmen werden jeweils als jpg-Bild (ohne Komprimierung) in einen eigenen Ordner
gespeichert.
•
Zur Auswertung der Bilder und zur Kalibrierung wird das Programm ImageJ geöffnet. Eines
der Kalibrierungsbilder wird geöffnet (z.B. für das 100x-Objektiv, quer): File → Open →
[Ordner + Datei auswählen].
•
Zur Analyse wird Analyze → Set Scale ausgewählt. Durch Anklicken des Auswahlkästchens
Global wird wird die vorgenommene Kalibrierung auf alle Bilder dieses Programmlaufs
angewandt. Mit OK bestätigt.
•
Um eine Messskala zu erhalten, wird im Hauptmenü eine Linie ausgewählt. Diese wird
zwischen den jeweils rechten oder linken Kanten der Kalibrierlinien gezogen. Dann wird
wieder
Analyze → Set Scale ausgewählt. Die Länge der Linie in Pixel hat ImageJ bereits
eingetragen, allerdings nicht die durch das Objektmikrometer vorgegebene tatsächliche
105
VERSUCH 5: MIKROSKOPISCHE BILDVERARBEITUNG
Länge in µm. Nachdem diese eingetragen ist, hat ImageJ diese Einstellungen für alle weiteren
zu bearbeitenden Bilder übernommen.
MESSUNG
DER
GRÖSSE
DER
LATEX-KÜGELCHEN
•
Zur Bestimmung der Größe der Beads werden zuerst 1 – 2 µl auf einen Objektträger
getropft und direkt mit einem Deckglas abgedeckt. Mit einem möglichst hoch
vergrößernden Objektiv werden nun einige Aufnahmen werden mit der
Mikroskopkamera aufgenommen.
•
Um aus den Bildern die Größenverteilung der Partikel zu bestimmen muss das
aufgenommene Grauwertbild in ein Binärbild umgewandelt werden. Dies geschieht mit
dem Schwellwertoperator von ImageJ (Threshold). Die Schwellenwerte müssen gesetzt
werden (Image → Adjust → Threshold) – die untere wird ganz niedrig gesetzt (≈ 0), die
obere je nach Bedarf, also nahe unterhalb des Peaks. Wenn der Schwellwert richtig gesetzt
wurde, müssen die Partikel schwarz sein, der Hintergrund weiß.
•
Da die Teilchen nicht immer rund sind und Kontaminationen (meistens keineswegs rund)
eliminiert werden sollen, werden die Partikel mittels Opening geglättet: Process → Binary
→ Erode (2 – 3x) und nachfolgend Process → Binary → Dilate (gleich oft!).
•
Um die Partikel zu analysieren, wechselt man in das Menü Analyze → Analyze Particles.
Wenn man eine Mindest- und Maximalgröße eingibt (z.B. 5-300 Pixel) und auswählt, dass
die Resultate angezeigt werden (Analyze Particles, etc.), erhält man den Mittelwert der
Größe, also den Durchmesser oder die Kreisfläche (A = ¼ π d2 )
AUFNAHME
EINES
„RANDOM-WALK“
UND
BESTIMMUNG
DES
DIFFUSIONSKOEFFIZIENTEN
•
Aus einem Stück Doppelklebeband wird ein Loch ausgestanzt. Der Objektträger wird sehr
gut gereinigt, um auch wirklich sicherzustellen, dass die meisten Kontaminationen
beseitigt werden. Das ausgestanzte Klebeband wird aufgeklebt und glatt gestrichen. Etwa
10 µl der (ca. 1:100 verdünnten) Beads werden in das Loch gefüllt. Das Deckglas wird
vorsichtig aufgelegt und festgedrückt. Die überschüssige Flüssigkeit wird entfernt. Die
ganze Apparatur muss gut abgedichtet sein (geschlossenes System), sonst entstehen
konvektive Bewegungen. Die Brown’sche Molekularbewegung kann dann nicht mehr
beobachtet werden, da sie durch die Drift überlagert wird.
•
Die Beads werden unter dem 40x-Objektiv betrachtet. Die Suspension darf nicht zu dicht
sein, da sonst die Auswertung erschwert wird. Außerdem sollten sich die Partikel
ungehindert bewegen können und nicht unter dem Deckglas festgeklemmt sein.
•
Es wird die Bewegung eines Partikels mittels Bildsequenz aufgenommen, und zwar im
Dunkelfeld bei 40facher Vergrößerung. Die Bildsequenz wird mittels der Kamera-Software
IC Capture Standard aufgenommen: Sequence Settings (Jeder Sequenz einen neuen Namen
geben!). Es soll etwa 30 bis 45 Sekunden lang mindestens jede Sekunde ein Bild
aufgenommen werden. Die Sequenz wird mit Sequence Timer → Start Timer begonnen und
mit Stop abgebrochen. Anschließend wird der Dateiname wieder verändert. Mehrere
solcher Sequenzen werden aufgenommen.
•
Die Auswertung erfolgt wiederum mit ImageJ. Die Bilder werden importiert (File → Import
→ Image Sequence → erstes Bild auswählen → Convert to 8-bit Greyscale auswählen → OK). Die
Sequenz kann jetzt als Stack (Bildstapel) abgespeichert werden (File → Save as → Tiff).
106
PHYSIKALISCH-TECHNISCHE METHODEN IN DER BIOLOGIE
•
Aus dem Stack kann ein Partikel zur weiteren Beobachtung ausgesucht und
ausgeschnitten werden ([Rechteckmaske] → Image → Crop).
•
Die Schwellenwerte werden so gesetzt, dass der Partikel als einziges schwarz erscheint,
der Hintergrund hingegen weiß (Image → Adjust → Threshold → obere Grenze ganz nach
oben, untere variabel rechts des Peaks → Apply → [Alles auswählen] → OK). Es entsteht ein
Binärbild.
•
Wenn das Teilchen sich nicht klar abgrenzt, muss es – wie oben beschrieben – mit Erode /
Dilate bearbeitet werden. Am Ende sollte in diesem Bereich nur ein einziges, sich
bewegendes Teilchen vorliegen.
•
Das Plugin Multitracker, welches nicht im Grundumfang von ImageJ enthalten ist, wird
verwendet, um die Bewegung des Partikels auszuwerten, also um seine Koordinaten zu
bestimmen.
•
Die Plugins Time Stamper (Anzeige der Zeit) bzw. Slice Remover (löscht Bilder aus einer
Sequenz) können nützlich sein. Im Multitracker wählt man die Größe aus. Weiterhin soll
der Aufenthaltsort angezeigt werden (Show Positions / Paths / Labels auswählen) – dabei wird
die Verschiebung des Teilchens auf zwei orthogonale Achsen projiziert.
•
Die Tabelle mit den X- und Y-Koordinatenwerten (in µm) wird als xy.dat abgespeichert.
Aus ihr wird die erste Zeile mit WordPad entfernt.
•
Weiterhin soll in Microsoft Excel die mittlere quadratische Verschiebung für die
verschiedene Zeitintervalle errechnet werden. Nach Pythagoras ergibt sich aus den
Summen der Quadrate der Verschiebungen in X- und Y-Richtung die quadratische
Wegstrecke r2.
•
Für jede Zeitdifferenz ∆t wird der arithmetische Mittelwert von ca. 5-10 Wegstrecken
berechnet und über ∆t aufgetragen werden. Eine Ausgleichgerade wird eingezeichnet. Die
Steigung wird berechnet.
•
Berechnen Sie aus Ihrer Messung den Diffusionskoeffizienten der Latexpartikel. Gehen
Sie dabei von der Einstein-Smoluchowski-Gleichung für den zweidimensionalen Fall aus.
•
Berechnen Sie mit diesem Diffusionskoeffizienten anhand der Einstein-Stokes Gleichung
den Wert der Boltzmann-Konstanten k. Die Viskosität η von Wasser bei 20°C ist 1,002 mPa
s bei 30°C 0,789 mPa s.
LITERATUR
1. Haberäcker P.: Digitale Bildverarbeitung – Grundlagen und Anwendungen, 3. Aufl., Carl
Hanser Verlag München Wien, 1989
2. Wehlan H.: Skript zur Vorlesung „Digitale Bildverarbeitung – Einführung in die
Grundlagen
3. Berg, H.C.: Random Walks in Biology. Princeton University Press, 1993
Alle Bilder in diesem Skript wurden mit dem freien Bildverarbeitungsprogram ImageJ aus dem
NIH bearbeitet, das Sie auch für die Durchführung des Kurses verwenden. Man findet dieses
Program im WWW unter der Adresse: http://rsb.info.nih.gov/ij/
107
VERSUCH 5: MIKROSKOPISCHE BILDVERARBEITUNG
108

Documentos relacionados